Bug 243058 - installer treats identical drives on VIA KM266 as software RAID
installer treats identical drives on VIA KM266 as software RAID
Status: CLOSED DUPLICATE of bug 409931
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 23:59 EDT by Jason Frothingham
Modified: 2008-04-24 10:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 10:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Frothingham 2007-06-06 23:59:41 EDT
Description of problem: When running the Fedora 7 installer, when selecting the
drives, the Fedora installer treats identically sized drives on an VIA KM266
chain as a software raid, rather than as separate drives. No RAID is configured
in the bios. 

The type of RAID also is a little interesting. On identically sized 120gig
Maxtor Drives, the KDE LiveCD configured the drives as a spanned raid.  On
identically sized 60gig Seagate drives, the drives are mapped as mirrors.  

The consistent portion is the drives appearing as mapper/*something*

When only a single drive is present, or when identically sized drives, but
different models are present, the installer presents the typical hd/sd entry tag.

This is somewhat complicated by a single drive on the slave IDE channel
reporting as /sda, even when another drive is present on the master channel.

An additional issue from this is the lack of an option to choose a different
drive than the one automatically selected for installation if a previous Fedora
installation was present. 


Version-Release number of selected component (if applicable): Fedora 7 DVD /
Fedora 7 KDE LiveCD


How reproducible: Reproduced on Seagate and Maxtor IDE drives, 60gig on the
seagates, 120gig on the Maxtor drives. Encountered installation problems on FIC
AM37 motheboard : chipset listed as VIA ProSavageDDR KM266


Steps to Reproduce:
1. start installer
2. get to drive selection screen
3. find that a software RAID has been set
  
Actual results:

No install was completed. Had to swap out drives for one that the installer
wouldn't try to set a RAID on.


Expected results: 

Most other Linux's, exampling Mepis and PClinuxOS had no problems correctly
assigning HDA status, and had no problems not setting as Software RAID on the
drives.


Additional info: 
I'm not really expecting anything to come out of this. I can't imagine that most
testers have identical model drives in order to test different versions of an
Operating System on identical hardware.
Comment 1 Jeremy Katz 2007-06-25 13:16:04 EDT
Do you have RAID enabled in your BIOS?  It sounds like there is existing IDE
"fakeraid" metadata on the disks and so we set them up as such.  Adding
'nodmraid' to your boot command line should tell the installer not to listen to
this information.
Comment 2 Jason Frothingham 2007-06-25 16:54:12 EDT
the BIOS has no RAID option set.  Other distributions, as stated specifically
Mepis and PCLinuxOS, experienced no issues in assigning correct identification
to the drives. 
Comment 3 Joel Andres Granados 2008-04-24 10:17:20 EDT
There is a bug where the dmraid stuff just blocks.  This bug has not been solved
yet and we are still working to fix it.   However there is a work around.  If
you use nodmraid, the installer will ignore/skip the dmraid stuff allowing the
install to finish.  This is a workaround and does not fix the problem.
There is a long list of bugs that are filed against this problem.  This bug is
one of them.  We have decided to close all the related nodmraid bugs and leave
just one open that will represent all of the others.  So this bug will be duped
for this reason.

*** This bug has been marked as a duplicate of 409931 ***

Note You need to log in before you can comment on or make changes to this bug.