Bug 243071 - memory leak in arcmsr 1.20.0x.13?pci_alloc_consistent/pci_free_consistent?
memory leak in arcmsr 1.20.0x.13?pci_alloc_consistent/pci_free_consistent?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tomas Henzl
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 03:02 EDT by Baif
Modified: 2007-11-16 20:14 EST (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.9-55.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 05:18:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Baif 2007-06-07 03:02:33 EDT
Description of problem:

pci_free_consistent would NOT "free" the "pci_alloc_consistent"-ed memory, 
with more than 4GB memory on Intel platform, work with Areca SATA host 
adapter.


Version-Release number of selected component (if applicable):

kernel-2.6.9-55.EL
SMP x86_64, with more than 4GB memory
Intel platform
1.20.0X.13-61107
CLI  V1.72.250_70306


How reproducible:

Steps to Reproduce:
1. Make and install arcmsr.ko for Areca SATA host adapter
2. Looping cli of Areca (while true;do ./cli64 sys info; done)
3. 1M/s redusing.
  
Actual results:


Expected results:


Additional info:
Comment 1 Albert Fluegel 2007-06-12 10:02:28 EDT
I think we are facing the same issue in a different context. On an Intel based
HP machine (this one:
http://h71028.www7.hp.com/enterprise/cache/445600-0-0-0-121.html) with 16 GB
memory, same kernel, x86_64: the cciss driver causes memory leaks. In the driver
specific ioctl called with CCISS_PASSTHRU it uses pci_alloc_consistent /
pci_free_consistent and doing such calls more and more memory is reported "in
use". How to reproduce: Install the hpasm Software from HP (can be obtained
here:
http://h20293.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=T2812AA)
and start it. To see memory being wasted faster, edit
/opt/compaq/storage/etc/cmaidad and set PFLAGS="-p 1 -s OK"
A process is visible:
cmaidad -p 1 -s OK
Attaching strace to this process, one can see the ioctl calls on the cciss
driver. Calling "free" repeatedly, the memory "in use" increases rapidly.
Comment 2 Baif 2007-06-14 01:53:49 EDT
Yes. The same issue.
Comment 3 Tomas Henzl 2007-09-18 04:42:54 EDT
Nick,

please could you check this issue ?
Comment 4 Albert Fluegel 2007-09-18 06:09:41 EDT
Hi,

FYI

As far as i can say, the fix is in kernel-2.6.9-55.9 , at least with this
kernel we don't see the problem anymore.

Thanks !
Comment 5 Tomas Henzl 2007-09-18 09:51:07 EDT
It seems to me that the problem is the same as the one in bz #233399 where it
was cleared. 
Unless someone will report that also newer kernels are having this problem, I'll
close this bz in a couple of days.
Comment 6 nickcheng 2007-09-18 21:33:49 EDT
yes, it seems to happen in the specific kernel version.
In newer versions, we don't see the problem any more.
Comment 7 Baif 2007-09-19 00:26:37 EDT
Thanks nickcheng and Albert Fluegel.
Tomas, this bz may be colsed soon, as you wish.
Comment 8 Tomas Henzl 2007-10-01 05:18:38 EDT
Thanks to all who participated on this.

I'm closing this bz now, as the problem only appeared in kernel-2.6.9-55.EL.

Note You need to log in before you can comment on or make changes to this bug.