Bug 243098 - pxeos command information incomplete
pxeos command information incomplete
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Installation_Guide (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ruediger Landmann
ecs-bugs
http://www.redhat.com/docs/manuals/en...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 06:20 EDT by Fred New
Modified: 2012-04-12 21:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 21:07:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred New 2007-06-07 06:20:44 EDT
Description of problem:
I am trying to set up an installation server with no previous experience.  I am
unable to make any sense of the information provided in the online System
Administration Guide and the pxeos man page.

Version-Release number of selected component (if applicable):
  See related URL.

How reproducible:
  Always

Steps to Reproduce:
1. Try to read the documentation concerning the pxeos command:
pxeos -a -i "<description>" -p <NFS|HTTP|FTP> -D 0 -s client.example.com \
 -L <net-location> -k <kernel> \
 -K <kickstart><os-identifer>
  
Actual results:
The answers to the following questions remain unanswered:
  What do I use as the -L parameter if I am setting up an NFS server?
  What do I use as the -k parameter?
  What do I use as the -K parameter?

Expected results:
  The answers to the above questions along with a few examples.

Additional info:
  For my installation (TFTP) server is also my NFS and DHCP server.
  My installation directory for RHEL 4, i386 is
    /home/install/rh-es-4
  My kickstart file is
    /home/install/rh-es-4/ks.cfg
  If my server has an IP address of 192.168.0.1, what is the pxeos command that
would set this up?
  Some examples for system-config-netboot would probably be useful, too.
  And it is confusing to give a server a name of "client", so it might be better
to have "-s installer.example.com".
Comment 1 Don Domingo 2007-06-12 21:33:09 EDT
making this bug block 241618, for queueing
Comment 2 Fred New 2007-06-13 02:18:43 EDT
I've managed to set up an installation server using the graphical
system-config-netboot facility, so I have answered some of my own questions.

First, it looks like "<kickstart>" and "<os-identifer>" should be separated by a
space.  The command line shown doesn't have one.

For my NFS case, I think the kickstart parameter (-K) should be
     nfs:192.168.0.1:/home/install/rh-es-4/ks.cfg
And I assume an http example would be
     http://192.168.0.1/install/rh-es-4/ks.cfg
You could check that this works with a browser beforehand.

The kernel parameter (-k) is confusing because it says "version".  So can you
use "2.6"?  I think this parameter probably wants the location of the kernel you
will boot for installing this system.  Maybe
     /home/install/rh-es-4/images/pxeboot/vmlinuz
is the correct setting.

Another question is how is the pxeboot command related to the pxeos command? 
Could we see a sample server setup that uses both pxeboot and pxeos?  And should
 there be a space between "<value>" and "<host>" in the pxeboot command?
(http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/en-US/System_Administration_Guide/Adding_PXE_Hosts-Command_Line_Configuration.html)?
Comment 5 Ruediger Landmann 2011-01-05 01:30:16 EST
Some of the issues raised in this very old bug have persisted to the current version of the Red Hat Enterprise Linux 5 Installation Guide. I've addressed them in build 3.1-11, with:

* expanded definitions for the -L, -K, and -k options
* changed name of example server to installer.example.com
* added a note about the existence of the pxeboot tool as an alternative

The issue of the space between <value> and <host> must have been addressed some time previously; it was already present in recent versions of the guide.

New version of the text:

34.2.1. Command Line Configuration
If the network server is not running X, the pxeos command line utility, which is part of the system-config-netboot-cmd package, can be used to configure the tftp server files as described in Section 34.4, “TFTPD”:

pxeos -a -i "<description>" -p <NFS|HTTP|FTP> -D 0 -s installer.example.com \ 
-L <location> -k <kernel> -K <kickstart> <os-identifer>

The following list explains the options:

    *
      -a — Specifies that an OS instance is being added to the PXE configuration.
    *
      -i "<description>" — Replace "<description>" with a description of the OS instance.
    *
      -p <NFS|HTTP|FTP> — Specify which of the NFS, FTP, or HTTP protocols to use for installation. Only one may be specified.
    *
      -D <0|1> — Specify "0" which indicates that it is not a diskless configuration since pxeos can be used to configure a diskless environment as well.
    *
      -s installer.example.com — Provide the name of the NFS, FTP, or HTTP server after the -s option.
    *
      -L <location> — Provide the location of the installation tree on that server after the -L option.
      For example, if the installation tree is exported as /install/rhel5 on an NFS share, specify -L /install/rhel5.
    *
      -k <kernel> — Provide the specific kernel for booting. Installation trees can contain multiple kernels.
      For example, if the installation tree contain a patched kernel named vmlinuz-du alongside the standard kernel named vmlinuz, use -k vmlinuz-du to specify the patched kernel.
    *
      -K <kickstart> — Provide the location of the kickstart file, if available. Specify this location as a full path, including the protocol; for example: -K nfs:192.168.0.1:/install/rhel5/ks.cfg
    *
      <os-identifer> — Specify the OS identifier, which is used as the directory name in the /tftpboot/linux-install/ directory. 

If FTP is selected as the installation protocol and anonymous login is not available, specify a username and password for login, with the following options before <os-identifer> in the previous command:

-A 0 -u <username> -p <password>

pxeos writes the results to the /tftpboot/linux-install/pxelinux.cfg/pxeos.xml file.
For more information on command line options available for the pxeos command, refer to the pxeos man page.
The pxeboot tool can also edit the /tftpboot/linux-install/pxelinux.cfg/pxeos.xml file and uses similar options to pxeos. Refer to the pxeboot man page for more detail.

Note You need to log in before you can comment on or make changes to this bug.