Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 243117 - Failed interpackage dependencies are silently ignored
Failed interpackage dependencies are silently ignored
Status: CLOSED DUPLICATE of bug 244077
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 08:28 EDT by Jan Kratochvil
Modified: 2013-01-09 23:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 13:30:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2007-06-07 08:28:34 EDT
Description of problem:
I was getting a weird build error and it was due to unsatisfied package
dependency.  It was not shown anywhere, it should be a build error.
Originally postde in Bug 242880 Comment 1.

Version-Release number of selected component (if applicable):
mock-0.6.12-1.fc7.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Type `exclude=rpmdevtools' (or some other essential rpm) into /etc/mock/*.cfg
2. Try to mock-build a package
3. See the build error without any notice the rpm was not found
  
Actual results:
Build error is shown without any notice the rpm was not found:
+ /usr/lib/rpm/check-buildroot
/var/tmp/rpm-tmp.20364: line 58: /usr/lib/rpm/check-buildroot: No such file or
directory
error: Bad exit status from /var/tmp/rpm-tmp.20364 (%install)

Expected results:
Error: Unable to find rpm rpmdevtools.

Additional info:
It may be related to suppressing inclusion of i386 packages for x86_64 builds.
The current solution is too general, though.
Some package were building differently if a package was missing, needing the
BuildRequires inclusion; some problems may persist due to this bug.
Comment 1 Jesse Keating 2007-06-13 13:30:48 EDT
This is actually a bug in yum.

*** This bug has been marked as a duplicate of 244077 ***

Note You need to log in before you can comment on or make changes to this bug.