Bug 243119 - Wrong init script
Wrong init script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Steven Dake
:
Depends On:
Blocks: 237789 309621
  Show dependency treegraph
 
Reported: 2007-06-07 08:53 EDT by Michal Marciniszyn
Modified: 2016-04-26 10:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0599
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:00:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-06-07 08:53:24 EDT
Description of problem:
The openais init scrip returns incorrect error codes and do not call status
command sometime. Problem is in following line:
[ -x "$exec" ] || exit 0
that if we change permissions on executable will always end script with error
code 0.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 RHEL Product and Program Management 2007-06-07 09:04:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Jakub Hrozek 2007-09-27 14:15:13 EDT
The fix included in 5.1 packages (openais-0.80.3-4.el5) is only half of the 
fix needed. The removal of "[ -x "$exec" ] || exit 0" at the top of the script 
must be complemented with adding "[ -x "$exec" ] || exit 5" as a first line of 
the start() function. (Note the LSB return codes spec: 5 - the program is not 
installed)

Because the fix included in 5.1 is better that the previous solution (throws 
an error message and has $? != 0 vs. no error message and $? = 0 in 5.0) and 
it's also quite late stage for 5.1 I propose we leave the fix in 5.1 as-is and 
fix the initscript properly in 5.2 or whenever the next release of openais 
will be.
Comment 9 errata-xmlrpc 2007-11-07 12:00:05 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0599.html

Note You need to log in before you can comment on or make changes to this bug.