Bug 243120 - /bin/pwd broken.
/bin/pwd broken.
Status: CLOSED DUPLICATE of bug 227168
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
6
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 08:54 EDT by jsuthan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 09:02:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jsuthan 2007-06-07 08:54:37 EDT
Description of problem:
/bin/pwd doesn't work when called using full path. 

Version-Release number of selected component (if applicable):
pwd (GNU coreutils) 5.97

How reproducible:

By just execute command using full path. 

Steps to Reproduce:
1. just run the command "/bin/pwd" getting error.
  
Actual results:
[suthan@falcon]~%
[suthan@falcon]~% pwd
/home/suthan
[suthan@falcon]~% /bin/pwd
/bin/pwd: cannot open directory `..': Permission denied
[suthan@falcon]~% pwd
/home/suthan
[suthan@falcon]~% tcsh
suthan has logged on pts/1 from solaris.
suthan has logged on smb/1 from xxxxxxx.
home{suthan}pwd
pwd: cannot open directory `..': Permission denied
Exit 1


Expected results:
[suthan@falcon]~% pwd
/home/suthan


Additional info:
Comment 1 Tim Waugh 2007-06-07 09:02:43 EDT

*** This bug has been marked as a duplicate of 227168 ***

Note You need to log in before you can comment on or make changes to this bug.