Bug 243168 - Dovecot .99 Leaves LF at beginning of mbox
Summary: Dovecot .99 Leaves LF at beginning of mbox
Status: CLOSED DUPLICATE of bug 235750
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
(Show other bugs)
Version: 4.5
Hardware: i386 Linux
low
low
Target Milestone: ---
: ---
Assignee: Tomas Janousek
QA Contact:
URL: http://ew3d.com
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-07 17:23 UTC by John Hinton
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 08:48:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Hinton 2007-06-07 17:23:20 UTC
Description of problem: Dovecot randomly leaves behind a LF at the beginning of
mbox mail files. This kills the ability for email users to access their email
boxes from email clients such as Outlook and also prevents SquirrelMail from
showing any messages, but instead it returns an error message.

This has been noted on the Dovecot website and has been fixed in version 1.0.


Version-Release number of selected component (if applicable):

From what I read, any version prior to 1.0


How reproducible:

Totally random. I have no idea what causes this. I can only guess that it is
being left behind from a previous email which has been removed from the file,
therefore there is nothing left to look at except the empty LF.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Opening the mailfile in VI, deleting the blank LF at the top of the file fixes
the problem... until or if it happens again.

This seems to be a totally random event which happens on various mailboxes. We
simply get a call that the user can't access their email. No particular account
and no particular server.

Comment 1 Tomas Janousek 2007-06-08 08:48:56 UTC

*** This bug has been marked as a duplicate of 235750 ***


Note You need to log in before you can comment on or make changes to this bug.