Bug 24317 - generated deps don't list '-include'-ed files
generated deps don't list '-include'-ed files
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cpp (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-18 17:49 EST by David Baron
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 13:36:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhbug24317.tar.gz - contains Makefile, incltest.c, and incltest.h (409 bytes, application/x-gzip)
2001-01-18 17:52 EST, David Baron
no flags Details

  None (edit)
Description David Baron 2001-01-18 17:49:57 EST
With cpp and gcc 2.96-69 and 2.96-70, the compiler-generated
dependencies (-Wp,-MD,file) don't list files included via
-include.  (In gcc 2.91, such files were listed.)

I'll attach a testcase that compiles using the command:

gcc -o incltest.o -include incltest.h -Wp,-MD,incltest.d incltest.c

This generates incltest.d containing:

incltest.o: incltest.c

If I set CC=kgcc (which is gcc 2.91), it generates incltest.d as:

incltest.o: incltest.c incltest.h

I noticed this because making configure.in changes to Mozilla that
modified config-deps.h (a file used instead of -D...) wasn't causing
a full rebuild anymore.  While this is actually sometimes useful, I
still think it's a bug.

I'll attach a testcase (in tar.gz) of the Makefile and test files
mentioned above.
Comment 1 David Baron 2001-01-18 17:52:45 EST
Created attachment 7828 [details]
rhbug24317.tar.gz - contains Makefile, incltest.c, and incltest.h
Comment 2 Jakub Jelinek 2001-01-24 13:36:03 EST
Patch submitted to gcc-patches, it will appear in cpp-2.96-72.

Note You need to log in before you can comment on or make changes to this bug.