Bug 243200 - Selinux alert with cups pdf
Selinux alert with cups pdf
Status: CLOSED DUPLICATE of bug 243605
Product: Fedora
Classification: Fedora
Component: cups-pdf (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-06-07 16:30 EDT by David Schmitz
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-11 12:28:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
selinux log file (2.39 KB, text/plain)
2007-06-07 16:30 EDT, David Schmitz
no flags Details

  None (edit)
Description David Schmitz 2007-06-07 16:30:50 EDT
Description of problem: look at the attach file

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 David Schmitz 2007-06-07 16:30:50 EDT
Created attachment 156506 [details]
selinux log file
Comment 2 Daniel Walsh 2007-06-11 08:51:00 EDT

Why is cups trying to write to the home dir?  Is this expected behavior?
Comment 3 Tim Waugh 2007-06-11 08:57:32 EDT
Dan, it's not CUPS code, it's cups-pdf which comes from the cups-pdf package

"SELinux is preventing /usr/lib/cups/backend/cups-pdf (cupsd_t) "write" to
schmitz (user_home_dir_t)."
Comment 4 Remi Collet 2007-06-11 12:28:00 EDT
Yes cups-pdf try to create "Desktop" folder in the user home.

In previous Fedora (<=6) this folder exists, so all is ok.

Since Fedora 7, it only exists on "english" locale (xdg-user-dirs).

I'm working with upstream to find a "good" solution.
Comment 5 Remi Collet 2007-06-11 12:28:43 EDT

*** This bug has been marked as a duplicate of 243605 ***

Note You need to log in before you can comment on or make changes to this bug.