Bug 243224 - Multilib problems on removing duplicate packages
Summary: Multilib problems on removing duplicate packages
Status: CLOSED DUPLICATE of bug 209306
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: multilib
TreeView+ depends on / blocked
 
Reported: 2007-06-08 00:36 UTC by Christoph Wickert
Modified: 2014-01-21 22:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 01:39:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christoph Wickert 2007-06-08 00:36:03 UTC
Description of problem:
On groupinstall yum installs two versions of a package, i386 and x86_64.
Removing one breaks the other.

Version-Release number of selected component (if applicable):
yum-3.2.0-1.fc7

How reproducible:
always

Steps to Reproduce:
1. do a "yum groupinstall XFCE" on a freshly installed F7 x86_64 system. This
will for example install two versions of exo, i386 and x86_64.
2. yum remove exo.i386
3. rpm -V exo
  
Actual results:
Locales and docs are gone.

Expected results:
All files included in the package should still be there.

Comment 1 Kevin Kofler 2007-06-08 01:39:52 UTC
That's a well-known RPM regression in FC6 caused by the Fedora RPM maintainer 
intentionally reverting a bugfix which wasn't broken and refusing to reenable 
it.

*** This bug has been marked as a duplicate of 209306 ***


Note You need to log in before you can comment on or make changes to this bug.