Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
This project is now read‑only. Starting Monday, February 2, please use https://ibm-ceph.atlassian.net/ for all bug tracking management.

Bug 2432370

Summary: ceph nfs cluster create cephfs-nfs command returns "no valid command found"
Product: [Red Hat Storage] Red Hat Ceph Storage Reporter: Vinayak Papnoi <vpapnoi>
Component: CephadmAssignee: Shweta Bhosale <shbhosal>
Status: CLOSED UPSTREAM QA Contact: Arunkumar Ravindranath <aravindr>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 8.1CC: cephqe-warriors, okomera, shbhosal, syeshwan
Target Milestone: ---Keywords: Automation, Regression
Target Release: 8.1z5   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: ceph-19.2.1-324.el9cp Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 2433184 (view as bug list) Environment:
Last Closed: 2026-03-05 07:26:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Vinayak Papnoi 2026-01-23 15:19:42 UTC
Description of problem:

The command "ceph nfs cluster create cephfs-nfs" returns invalid command :

2026-01-23 07:30:13,015 - cephci - ceph:1630 - INFO - Execute ceph mgr module enable nfs --force on 10.243.100.154
2026-01-23 07:30:14,019 - cephci - ceph:1660 - INFO - Execution of ceph mgr module enable nfs --force on 10.243.100.154 took 1.003284 seconds
2026-01-23 07:30:17,025 - cephci - ceph:1630 - INFO - Execute cat /etc/redhat-release on 10.243.100.152
2026-01-23 07:30:18,029 - cephci - ceph:1660 - INFO - Execution of cat /etc/redhat-release on 10.243.100.152 took 1.00371 seconds
2026-01-23 07:30:18,029 - cephci - cluster:116 - DEBUG - OS is not RHEL 10.1 (found: Red Hat Enterprise Linux release 9.7 (Plow))
2026-01-23 07:30:18,031 - cephci - ceph:1630 - INFO - Execute cat /etc/redhat-release on 10.243.100.153
2026-01-23 07:30:19,037 - cephci - ceph:1660 - INFO - Execution of cat /etc/redhat-release on 10.243.100.153 took 1.005843 seconds
2026-01-23 07:30:19,038 - cephci - cluster:116 - DEBUG - OS is not RHEL 10.1 (found: Red Hat Enterprise Linux release 9.7 (Plow))
2026-01-23 07:30:19,039 - cephci - ceph:1630 - INFO - Execute ceph nfs cluster create cephfs-nfs 'ceph-bvt177-xid7-6jgdil-node2' on 10.243.100.154
2026-01-23 07:30:20,044 - cephci - ceph:1660 - INFO - Execution of ceph nfs cluster create cephfs-nfs 'ceph-bvt177-xid7-6jgdil-node2' on 10.243.100.154 took 1.004036 seconds
2026-01-23 07:30:20,044 - cephci - nfs_verify_read_write_operations:176 - ERROR - Failed to validate read write operations : Failed to create NFS cluster: ceph nfs cluster create cephfs-nfs 'ceph-bvt177-xid7-6jgdil-node2' returned no valid command found; 10 closest matches:
pg stat
pg getmap
pg dump [<dumpcontents:all|summary|sum|delta|pools|osds|pgs|pgs_brief>...]
pg dump_json [<dumpcontents:all|summary|sum|pools|osds|pgs>...]
pg dump_pools_json
pg ls-by-pool <poolstr> [<states>...]
pg ls-by-primary <id|osd.id> [<pool:int>] [<states>...]
pg ls-by-osd <id|osd.id> [<pool:int>] [<states>...]
pg ls [<pool:int>] [<states>...]
pg dump_stuck [<stuckops:inactive|unclean|stale|undersized|degraded>...] [<threshold:int>]
Error EINVAL: invalid command
 and code 22 on 10.243.100.154


Version-Release number of selected component (if applicable):
19.2.1-321
rpm compose repo : http://download-01.beak-001.prod.iad2.dc.redhat.com/rhel-9/composes/auto/ceph-8.1-rhel-9/RHCEPH-8.1-RHEL-9-20260123.ci.1/
Ceph base image : quay.io/rhceph-ci/rhceph@sha256:0448e1d59c1abff2d559a4ed353c4b3f97720c79bb10255fd1c8808201dda0a7

How reproducible:
2/2

Steps to Reproduce:
1. Deploy a ceph 8.1 cluster
2. run the command mentioned in the description
3.

Actual results:
invalid command error

Expected results:
Command must be executed successfully

Additional info:

Comment 8 Red Hat Bugzilla 2026-03-05 07:26:03 UTC
This product has been discontinued or is no longer tracked in Red Hat Bugzilla.