Bug 243238 - [pata_via] DVD drive state machine violations
Summary: [pata_via] DVD drive state machine violations
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: athlon Linux
low
low
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 06:02 UTC by Neil Thompson
Modified: 2008-01-07 14:29 UTC (History)
3 users (show)

Fixed In Version: 2.6.23.9-85
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 14:29:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg and lspci (57.20 KB, text/plain)
2007-06-08 06:02 UTC, Neil Thompson
no flags Details
more log messages (2.93 KB, text/plain)
2007-06-08 15:33 UTC, Neil Thompson
no flags Details

Description Neil Thompson 2007-06-08 06:02:26 UTC
Description of problem:

Since upgrading to F7, I've been getting the following messages logged several
times an hour - 

Jun  3 09:13:06 eeyore kernel: ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0
action 0x2 frozen
Jun  3 09:13:06 eeyore kernel: ata2.00: (BMDMA stat 0x24)
Jun  3 09:13:06 eeyore kernel: ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0
tag 0 cdb 0x4a data 8 in
Jun  3 09:13:06 eeyore kernel:          res 58/00:02:00:08:00/00:00:00:00:00/a0
Emask 0x2 (HSM violation)
Jun  3 09:13:06 eeyore kernel: ata2: soft resetting port
Jun  3 09:13:07 eeyore kernel: ata2.00: configured for UDMA/33
Jun  3 09:13:07 eeyore kernel: ata2: EH complete

Version-Release number of selected component (if applicable):

kernel-2.6.21-1.3194.fc7.i686

How reproducible:

It happens without my input

Smolt profile: b7852bcb-30db-4c6b-9599-95e95c4bdbae

Comment 1 Neil Thompson 2007-06-08 06:02:26 UTC
Created attachment 156547 [details]
dmesg and lspci

Comment 2 Brianna 2007-06-08 11:16:25 UTC
After upgrading from FC6 to F7 I am receiving the same errors:
ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/01:00:00:00:00/00:00:00:00:00/b0 tag 0 cdb 0x4a data 8 in
         res 40/00:03:00:00:00/00:00:00:00:00/b0 Emask 0x4 (timeout)
ata2: soft resetting port
ata2.00: configured for UDMA/25
ata2.01: configured for UDMA/25
ata2: EH complete
((As a side note yesterday they were saying UDMA/33)
smolt: 70f1ac0f-9325-487a-80fc-5cd1d968b73e
kernel: 2.6.21-1.3194.fc7

Also while trying to correct display issues from a terminal screen that error
showed up on the screen about every 5 min and when that happened the HD light
would stay solid for 5-10 seconds then go back to normal. 



Comment 3 Neil Thompson 2007-06-08 15:33:17 UTC
Created attachment 156584 [details]
more log messages

Comment 4 Neil Thompson 2007-06-08 15:36:53 UTC
Comment on attachment 156584 [details]
more log messages

It's also affecting playing cds using gnome-cd and rhythmbox.  The player goes
silent and the attached messages appear in the log.  Once it's finished
complaining, the player starts again where it left off.

Comment 5 Alan Cox 2007-06-08 15:50:19 UTC
brianna: please file a seperate bug - different messages and probably a
different problem


Comment 6 Kyle 2007-06-19 05:41:32 UTC
I'm running F7 with all the latest updates and am seeing these errors.  It
causes some programs to hang for quite a while (warzone2100) before continuing.

Jun 18 22:39:01 host kernel: ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0
action 0x2 frozen
Jun 18 22:39:01 host kernel: ata6.00: cmd a0/00:00:00:00:20/00:00:00:00:00/a0
tag 0 cdb 0x0 data 0 
Jun 18 22:39:01 host kernel:          res 40/00:03:00:00:00/00:00:00:00:00/a0
Emask 0x4 (timeout)
Jun 18 22:39:01 host kernel: ata6: soft resetting port
Jun 18 22:39:01 host kernel: ata6.00: configured for PIO0
Jun 18 22:39:01 host kernel: ata6: EH complete


Comment 7 Alan Cox 2007-06-22 20:13:08 UTC
Kyle ditt o please file a different bug as you are reporting different problems.
In that bug include an lspci -vvxxx and dmesg so I can see what hardware is
involved. Thanks


Comment 8 Kyle 2007-06-23 02:35:19 UTC
Sorry about that.  I thought they were the same.  I've created bug 245426 as
you've requested.

Comment 9 Christopher Brown 2007-09-14 13:26:54 UTC
Hello Neil,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel? Could the people who have
filed separate bugs please not add any further comment as Alan has indicated you
do not have a duplicate issue.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 10 Neil Thompson 2008-01-07 14:29:49 UTC
I'm no longer on F7 and haven't seen this problem since I went to F8.

Closing


Note You need to log in before you can comment on or make changes to this bug.