Bug 24326 - extra ethernet interface
extra ethernet interface
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-18 19:26 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 17:38:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-18 19:26:15 EST
On i586 computer with two 
3com905 cards anaconda created 3 (not 2!) /etc/modules.conf ethernet
entries
during kickstart installation.

cat /etc/modules.conf
alias eth0 3c59x
alias eth1 3c59x
alias parport_lowlevel parport_pc
alias eth2 3c90x

cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 5
model		: 2
model name	: Pentium 75 - 200
stepping	: 5
cpu MHz		: 75.172
fdiv_bug	: no
hlt_bug		: no
sep_bug		: no
f00f_bug	: yes
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr mce cx8
bogomips	: 149.91

[root@clienthost /root]# cat /proc/pci     
PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: VLSI 82C592-FC1 (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable. 
Latency=16.    Bus  0, device   1, function  0:
    ISA bridge: VLSI 82C593-FC1 (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No
bursts.  
  Bus  0, device   2, function  0:
    VGA compatible controller: Cirrus Logic GD 5434 (rev 195).
      Fast devsel.  
      Non-prefetchable 32 bit memory at 0x40000000 [0x40000000].
  Bus  0, device   3, function  0:
    IDE interface: CMD 640 (buggy) (rev 2).
      Medium devsel.  IRQ 14.  
  Bus  0, device  19, function  0:
    Ethernet controller: 3Com 3C905B 100bTX (rev 36).
      Medium devsel.  IRQ 11.  Master Capable.  Latency=64.  Min Gnt=10.Max
Lat=10.
      I/O at 0x1000 [0x1001].
      Non-prefetchable 32 bit memory at 0x41000000 [0x41000000].
  Bus  0, device  20, function  0:
    Ethernet controller: 3Com Unknown device (rev 120).
      Vendor id=10b7. Device id=9200.
      Medium devsel.  IRQ 5.  Master Capable.  Latency=64.  Min Gnt=10.Max
Lat=10.
      I/O at 0x1080 [0x1081].
      Non-prefetchable 32 bit memory at 0x41080000 [0x41080000].
[root@clienthost /root]# 
dmesg
Linux version 2.2.16-22 (root@porky.devel.redhat.com) (gcc version
egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Tue Aug 22 16:16:55
EDT 2000
Detected 75172 kHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 149.91 BogoMIPS
Memory: 79156k/81920k available (1048k kernel code, 412k reserved, 1240k
data, 64k init, 0k bigmem)
Dentry hash table entries: 262144 (order 9, 2048k)
Buffer cache hash table entries: 131072 (order 7, 512k)
Page cache hash table entries: 32768 (order 5, 128k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium 75 - 200 stepping 05
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
Intel Pentium with F0 0F bug - workaround enabled.
POSIX conformance testing by UNIFIX
PCI: BIOS32 entry (0xc00f7db0) in high memory, cannot use.
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 131072 bhash 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing RT netlink socket
Starting kswapd v 1.5 
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
apm: BIOS version 1.1 Flags 0x0a (Driver version 1.13)
Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
CMD640: ignored by ide_scan_pci_device() (uses own driver)
ide0: buggy cmd640b interface on PCI (type1), config=0x3e
ide1: serialized, secondary interface enabled
cmd640: drive0 timings/prefetch(off) preserved
cmd640: drive1 timings/prefetch(off) preserved
cmd640: drive2 timings/prefetch(off) preserved
cmd640: drive3 timings/prefetch(off) preserved
hda: ST310212A, ATA DISK drive
hdd: CD-ROM CDU76E, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15 (serialized with ide0)
hda: ST310212A, 9768MB w/512kB Cache, CHS=19846/16/63
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
   8regs     :    71.247 MB/sec
   32regs    :    52.197 MB/sec
using fastest function: 8regs (71.247 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
 hda: [PTBL] [1245/255/63] hda1 hda2 < hda5 hda6 hda7 >
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 64k freed
Adding Swap: 208804k swap-space (priority -1)
3c59x.c:v0.99H 01Aug00 Donald Becker
http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
eth0: 3Com 3c905B Cyclone 100baseTx at 0x1000,  00:10:5a:ce:4c:20, IRQ 11
  8K byte-wide RAM 5:3 Rx:Tx split, autoselect/Autonegotiate interface.
  MII transceiver found at address 24, status 786d.
  MII transceiver found at address 0, status 786d.
  Enabling bus-master transmits and whole-frame receives.
eth1: 3Com 3c905C Tornado at 0x1080,  00:01:03:22:e0:cb, IRQ 5
  8K byte-wide RAM 5:3 Rx:Tx split, autoselect/Autonegotiate interface.
  MII transceiver found at address 24, status 7809.
  Enabling bus-master transmits and whole-frame receives.
parport0: PC-style at 0x378 (0x778) [SPP,ECP,ECPEPP,ECPPS2]
parport0: detected irq 7; use procfs to enable interrupt-driven operation.
parport_probe: failed
parport0: no IEEE-1284 device present.
lp0: using parport0 (polling).
cat uses obsolete /proc/pci interface
Comment 1 Michael Fulbright 2001-01-19 11:41:44 EST
Assigning to a developer.
Comment 2 Erik Troan 2001-01-30 17:38:17 EST
This happened because the 3c59x driver (inserted) first, was willing to drive
the 3c905 card, but the install wanted to use the 3c90x driver for that card.

This is a bug, but as the 3c90x driver won't exist as of the 2.4 kernel, I'm not
going to bother fixing it.

Note You need to log in before you can comment on or make changes to this bug.