Bug 243264 - Python aborts when using ldap module.
Summary: Python aborts when using ldap module.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-ldap
Version: 7
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 10:27 UTC by Yoshinori KUNIGA
Modified: 2007-11-30 22:12 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-06-13 21:03:55 UTC


Attachments (Terms of Use)
Script to reproduce. (69 bytes, text/plain)
2007-06-08 10:27 UTC, Yoshinori KUNIGA
no flags Details

Description Yoshinori KUNIGA 2007-06-08 10:27:43 UTC
Description of problem:
ldap.initialize() method fails.

Version-Release number of selected component (if applicable):
$ rpm -q python python-ldap
python-2.5-12.fc7
python-ldap-2.2.0-3

How reproducible:
Always

Steps to Reproduce:
Run attached script as 'python pyldap.py'.

Actual results:
Python aborts.

Expected results:
Python finishes normally.

Additional info:
This is attributed to the fact that version of python-ldap is old.

  http://python-ldap.cvs.sourceforge.net/python-ldap/python-ldap/CHANGES?view=markup

46 Released 2.2.1 2006-11-15
47 
48 Changes since 2.2.0:
49 
50 Modules/
51 * Fix for Python 2.5 free(): invalid pointer (see SF#1575329)
52 * passwd() accepts None for arguments user, oldpw, newpw
53   (see SF#1440151)

Comment 1 Yoshinori KUNIGA 2007-06-08 10:27:43 UTC
Created attachment 156562 [details]
Script to reproduce.

Comment 2 Matthew Barnes 2007-06-08 13:07:13 UTC
I've upgrade python-ldap in Rawhide to 2.3, but I'm a little hesitant about
bumping the version in a stable distro like Fedora 7.  Are there API changes
between 2.2.0 and 2.3 that may break applications?

Comment 3 Yoshinori KUNIGA 2007-06-09 10:54:34 UTC
Thanks for the swift response.  I compared the differences between output of
pydoc python-ldap-2.2.0 and python-ldap-2.3.  There is API addition but it
seems to there is no API changes.


Comment 4 Matthew Barnes 2007-06-09 15:58:33 UTC
Thanks for looking into it.  That seems pretty safe, and according to repoquery
only sabayon and luma use python-ldap.  I'll submit an update for Fedora 7 and
see if anyone objects.

Comment 5 Fedora Update System 2007-06-09 16:37:55 UTC
python-ldap-2.3-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Yoshinori KUNIGA 2007-06-11 07:16:43 UTC
This problem has been solved.  Thank you for your cooperation.

Comment 7 Fedora Update System 2007-06-13 21:03:52 UTC
python-ldap-2.3-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.