Bug 243304 - [NVidia] Some programs fail when Xinerama is on.
[NVidia] Some programs fail when Xinerama is on.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 09:52 EDT by Björn Persson
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: f7 before 2007-08-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 12:35:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Björn Persson 2007-06-08 09:52:26 EDT
Description of problem:
After upgrade from Fedora Core 6 to Fedora 7, Openoffice behaves just like the
command "true": It displays no windows, outputs nothing on stdout or stderr,
just terminates with an exit code of zero.

Version-Release number of selected component (if applicable):
2.2.0-14.8

How reproducible:
Always.

Steps to Reproduce:
1. Run oocalc, oodraw, ooffice, ooimpress, oomath, ooviewdoc or oowriter.
2. echo $?

Actual results:
No error messages, no log messages, no error codes, nothing. It just won't run.

Expected results:
Openoffice should display a GUI and let me edit documents and spreadsheets and
stuff. If it can't, I expect an error message and a nonzero exit code.

Additional info:
These packages are installed:
openoffice.org-langpack-sv-2.2.0-14.8
openoffice.org-impress-2.2.0-14.8
openoffice.org-core-2.2.0-14.8
openoffice.org-graphicfilter-2.2.0-14.8
openoffice.org-draw-2.2.0-14.8
openoffice.org-math-2.2.0-14.8
openoffice.org-calc-2.2.0-14.8
openoffice.org-writer-2.2.0-14.8
openoffice.org-xsltfilter-2.2.0-14.8

"rpm --verify --all 'openoffice.org*'" indicates no problems. And yes, it worked
just fine in Fedora 6.
Comment 1 Caolan McNamara 2007-06-08 09:53:52 EDT
Works fine for me, so...

What's your video driver ?
Comment 2 Björn Persson 2007-06-08 10:07:22 EDT
It's Nvidia's proprietary driver, installed from Livna. That was so before the
upgrade too. And of course the driver is upgraded to the packages for Fedora 7:
kmod-nvidia-1.0.9762-1.2.6.21_1.3194.fc7
xorg-x11-drv-nvidia-1.0.9762-2.lvn7
Comment 3 Caolan McNamara 2007-06-08 10:11:08 EDT
if you shut down OOo and in a gnome-terminal do...

export SAL_IGNOREXERRORS=YES
oowriter

does it then start ?
Comment 4 Björn Persson 2007-06-08 10:21:51 EDT
Well, SAL_IGNOREXERRORS=YES did help somewhat. At least I got an error message:

(swriter.bin:22191): Gdk-CRITICAL **: gdk_x11_get_xatom_by_name_for_display:
assertion `GDK_IS_DISPLAY (display)' failed

---start copy and paste here---
(I)    x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers//nvidia_drv.so
(III)  Desktop is: not GNOME
(IV)   libgcj version is: libgcj-4.1.2-12-x86_64 libgcj-4.1.2-12-i386
(V)    kernel is: Linux 2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:47:07 EDT 2007
x86_64 x86_64 x86_64
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.2.0-14.8-x86_64
(VII)    depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora release 7 (Moonshine)
...start free space details ...
Filsystem             1K-block    Använt Tillgängl Anv% Monterat på
/dev/mapper/VolGroup00-LV4
                      71640564  20148728  47793968  30% /home
/dev/mapper/VolGroup00-LV3
                      19838052   5646184  13167868  31% /
...end free space details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x0000003573836808: 0x00000000001e9d08:
/usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x36808
0x000000357383730b: 0x00000000001e9d08:
/usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x3730b
0x000000356be0dd20: 0x0000000000014db0: /lib64/libpthread.so.0 + 0xdd20
0x000000356f224570: 0x000000000003eaa8: /lib64/libgobject-2.0.so.0 + 0x24570
(g_type_check_instance_is_a + 0x40)
0x0000003451c50c0e: 0x00000000000914c0: /usr/lib64/libgdk-x11-2.0.so.0 + 0x50c0e
(gdk_x11_get_xatom_by_name_for_display + 0x2e)
0x0000003451c55d36: 0x00000000000914c0: /usr/lib64/libgdk-x11-2.0.so.0 + 0x55d36
(gdk_window_set_type_hint + 0xd6)
0x00000034526444eb: 0x000000000037e118: /usr/lib64/libgtk-x11-2.0.so.0 + 0x2444eb
0x000000356f20af19: 0x000000000003eaa8: /lib64/libgobject-2.0.so.0 + 0xaf19
(g_closure_invoke + 0x109)
0x000000356f21abce: 0x000000000003eaa8: /lib64/libgobject-2.0.so.0 + 0x1abce
0x000000356f21bbd4: 0x000000000003eaa8: /lib64/libgobject-2.0.so.0 + 0x1bbd4
(g_signal_emit_valist + 0x844)
0x000000356f21bda3: 0x000000000003eaa8: /lib64/libgobject-2.0.so.0 + 0x1bda3
(g_signal_emit + 0x83)
0x0000003452636e6f: 0x000000000037e118: /usr/lib64/libgtk-x11-2.0.so.0 +
0x236e6f (gtk_widget_realize + 0x8f)
0x00002aaaaeaec5e1: 0x0000000000050488:
/usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x3a5e1
0x00002aaaaeaed6e9: 0x0000000000050488:
/usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x3b6e9
0x00002aaaaeaef280: 0x0000000000050488:
/usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x3d280
0x00002aaaaeacca35: 0x0000000000050488:
/usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x1aa35
0x000000345047db43: 0x000000000039dd28:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0x27db43
0x000000345040a9fa: 0x000000000039dd28:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0x20a9fa
0x000000345040ab78: 0x000000000039dd28:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0x20ab78
0x000000345048d223: 0x000000000039dd28:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0x28d223
0x0000003450427faa: 0x000000000039dd28:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0x227faa
(IntroWindow::IntroWindow() + 0x4a)
0x00002aaab38fd8da: 0x0000000000034cb0:
/usr/lib64/openoffice.org/program/libspl680lx.so + 0x158da
0x00002aaab38fdb93: 0x0000000000034cb0:
/usr/lib64/openoffice.org/program/libspl680lx.so + 0x15b93
0x000000357224573d: 0x0000000000075038:
/usr/lib64/openoffice.org/program/libuno_cppuhelpergcc3.so.3 + 0x4573d
(cppu::OSingleFactoryHelper::createInstanceEveryTime(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0xbd)
0x000000357224554d: 0x0000000000075038:
/usr/lib64/openoffice.org/program/libuno_cppuhelpergcc3.so.3 + 0x4554d
(cppu::OSingleFactoryHelper::createInstanceWithContext(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0x1d)
0x0000003572245a8f: 0x0000000000075038:
/usr/lib64/openoffice.org/program/libuno_cppuhelpergcc3.so.3 + 0x45a8f
(cppu::OFactoryComponentHelper::createInstanceWithContext(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0xcf)
0x0000003572245e5b: 0x0000000000075038:
/usr/lib64/openoffice.org/program/libuno_cppuhelpergcc3.so.3 + 0x45e5b
(cppu::OSingleFactoryHelper::createInstanceWithArgumentsAndContext(com::sun::star::uno::Sequence<com::sun::star::uno::Any>
const&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0x2b)
0x000000357224606f: 0x0000000000075038:
/usr/lib64/openoffice.org/program/libuno_cppuhelpergcc3.so.3 + 0x4606f
(cppu::OFactoryComponentHelper::createInstanceWithArgumentsAndContext(com::sun::star::uno::Sequence<com::sun::star::uno::Any>
const&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0xdf)
0x00000035722450b8: 0x0000000000075038:
/usr/lib64/openoffice.org/program/libuno_cppuhelpergcc3.so.3 + 0x450b8
(cppu::ORegistryFactoryHelper::createInstanceWithArgumentsAndContext(com::sun::star::uno::Sequence<com::sun::star::uno::Any>
const&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0xc8)
0x00002aaab05b73fd: 0x000000000001ff18:
/usr/lib64/openoffice.org/program/servicemgr.uno.so + 0xf3fd
0x00002aaab05b72d2: 0x000000000001ff18:
/usr/lib64/openoffice.org/program/servicemgr.uno.so + 0xf2d2
0x0000003455c27096: 0x0000000000054798:
/usr/lib64/openoffice.org/program/libsoffice.so + 0x27096
(desktop::Desktop::OpenSplashScreen() + 0x1d6)
0x0000003455c27533: 0x0000000000054798:
/usr/lib64/openoffice.org/program/libsoffice.so + 0x27533
(desktop::Desktop::Main() + 0x133)
0x00000034502dd2a4: 0x000000000039dd28:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xdd2a4
0x00000034502dd305: 0x000000000039dd28:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xdd305 (SVMain() + 0x25)
0x0000003455c2142b: 0x0000000000054798:
/usr/lib64/openoffice.org/program/libsoffice.so + 0x2142b (main + 0x4b)
0x000000356a21daa4: 0x0000000000149b60: /lib64/libc.so.6 + 0x1daa4
(__libc_start_main + 0xf4)
0x0000000000400619: 0x0000000000000870:
/usr/lib64/openoffice.org/program/swriter.bin + 0x619 (main + 0x49)
...end stackreport details ...
...start sample ldd details ...
        libuno_sal.so.3 => /usr/lib64/openoffice.org/program/libuno_sal.so.3
(0x00002aaaaaccd000)
        libuno_salhelpergcc3.so.3 =>
/usr/lib64/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x00002aaaab0c2000)
        libstore.so.3 => /usr/lib64/openoffice.org/program/libstore.so.3
(0x00002aaaab2c6000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaab503000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaab707000)
        libstlport_gcc.so => /usr/lib64/openoffice.org/program/libstlport_gcc.so
(0x00002aaaab921000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaabbef000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaabeef000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaaac172000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaac381000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aaaac6d1000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
...end sample ldd details ...
---end copy and paste here---
Comment 5 Caolan McNamara 2007-06-08 10:29:45 EDT
I'd really like to see what happens if we use just the nv driver for a session
instead of the nvidia drivers.
Comment 6 Björn Persson 2007-06-09 18:07:45 EDT
Apparently Openoffice fails only when a second monitor is attached. Right now I
don't have the external monitor, and now I can't reproduce the problem;
Openoffice works with both the nv and nvidia drivers. As nv doesn't seem to work
when X is configured for two monitors, I have little hope of proving or
disproving that the problem is with the nvidia driver.

I'll test some more when I can connect the external monitor again.
Comment 7 Björn Persson 2007-06-12 13:22:33 EDT
OK, these are my findings:

First, the primary problem also affects some Gnome programs, so I'm changing the
component field to "xorg-x11". Gnome-terminal and gnome-screensaver-preferences
fail because of X errors, but unlike Openoffice they admit that there was an error:

"The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 101 error_code 8 request_code 78 minor_code 0)"

"The program 'gnome-screensaver-preferences' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadColor (invalid Colormap parameter)'.
  (Details: serial 232 error_code 12 request_code 1 minor_code 0)"

Locking the console doesn't work either in Gnome. No error message is displayed
in the GUI for that. (I can't check whether anything is written on stderr as I
don't know the command to run that from a terminal.)

Second, the problem occurs only when:
1: there are two screens configured in xorg.conf,
2: the Xinerama option is on, and
3: the second monitor is actually plugged in.
If any one of these conditions isn't fulfilled, then Openoffice and the Gnome
programs work.

I can't know whether the problem is in Xinerama or in the proprietary driver, as
the nv driver only works in configurations where the problem doesn't occur anyway.

I have opened bug 243904 for the lack of error message, as that is obvously a
separate bug.
Comment 8 Björn Persson 2007-08-13 15:48:04 EDT
This problem seems to have disappeared. At least I can't reproduce it right now.
I don't know which update fixed it.
Comment 9 Matěj Cepl 2007-08-15 12:35:08 EDT
closing per reporter's comment 8.

Note You need to log in before you can comment on or make changes to this bug.