Bug 243418 - script sccs2rcs is has broken #! line
script sccs2rcs is has broken #! line
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cvs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 12:44 EDT by Stepan Kasal
Modified: 2013-07-02 19:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 06:45:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2007-06-08 12:44:01 EDT
The first line of script /usr/share/cvs/contrib/sccs2rcs is
  #! no -f
which is obviously wrong.

I guess the reason is that ./configure detected "no" csh.  (The script is
written in csh.)

While fixing the problem, we have to take care that cvs does not become
dependant on csh.

I see several options:
1) fix the #! line, but tell the find-requires to ignore this (chmod -x the script?)
2) drop the script
3) accept the perl rewrite of sccs2rcs which was present in FC 3 and RHEL 4, but
refused upstream (for details, see bug #57974 and
http://lists.gnu.org/archive/html/info-cvs/2002-03/msg00273.html)

This problem is present not only in current devel, but also in RHEL-5 and in
Fedora Core 4--Fedora 7.
Comment 1 Stepan Kasal 2007-06-18 09:16:57 EDT
Fixed, using option 1).

Note You need to log in before you can comment on or make changes to this bug.