Bug 243428 - F7 Install/Rescue CD fails to find PATA drives, pdc202 driver
F7 Install/Rescue CD fails to find PATA drives, pdc202 driver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 13:14 EDT by John Dennis
Modified: 2008-06-16 21:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci, lspci -n, lspci -v (4.53 KB, text/plain)
2007-06-08 13:14 EDT, John Dennis
no flags Details
output of lscpi (8.55 KB, text/plain)
2007-09-17 11:25 EDT, John Dennis
no flags Details
Output from lspci -vvxx (7.68 KB, text/plain)
2007-09-23 08:42 EDT, Ian Waring
no flags Details
Output from dmesg (18.42 KB, text/plain)
2007-09-23 08:43 EDT, Ian Waring
no flags Details

  None (edit)
Description John Dennis 2007-06-08 13:14:18 EDT
Unable to install from either the F7 rescue CD or install CD apparently because
the kernel loaded off the CD is unable to successfully initialize the PATA
driver.  This is a somewhat older DELL with a Pentium 3. 

During the phase where each driver is being loaded and displayed the driver name
will become garbled with random glyphs with some type of corruption. I believe,
but I'm not 100% sure, the driver being loaded just prior to the message area
becoming corrupted is:

pdc202xx_old

Eventually the kernel boot phase will complete but the rescue/install complains
there are no hard drives. I suspect it's because the driver for the Promise
Technology Mass Storage Controler PDC20262 faulted somehow during it's
initialization. I've attached output from lspci listing the PCI devices on the
system. The good news is it seems to be correctly identifying the correct driver
to load, the bad new is the load of that driver fails.
Comment 1 John Dennis 2007-06-08 13:14:18 EDT
Created attachment 156594 [details]
output of lspci, lspci -n, lspci -v
Comment 2 Andre Robatino 2007-06-08 13:47:24 EDT
  This might be related to my bug #242766.
Comment 3 John Dennis 2007-06-21 09:27:04 EDT
Any progress on this?
Comment 4 Christopher Brown 2007-09-14 10:26:55 EDT
Hello John,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 5 John Dennis 2007-09-14 17:19:59 EDT
I just discovered the root cause of the problem. The IDE drive had been
connected to a PCI IDE controller, not to one of the IDE controllers on the
motherboard. I figured this out when I went into the bios to look at the device
configuration and discovered the bios thought the primary IDE was absent and in
fact that socket on the motherboard was unpopulated. Since the motherboard IDE
socket was available I removed the IDE cable the drive was attached from the PCI
IDE controler and plugged the IDE cable into the motherboard socket. At that
point the bios saw the drive and the kernel driver loading succeeded.

This is a regression. This particular box has been in aforementioned
configuration for years and I've never had trouble loading an OS before, perhaps
one of the reasons I didn't open the box to see what the IDE cables were
attached to. After a discussion with some of the kernel guys I'm fairly certain
one of the drivers the kernel was loading was crashing.

The short summary is the presence of a PCI IDE controller seemed to have
triggered the aberant behavior.

The fact the disk was not visible to the bios may be a triggering factor, but
like I said, this had not been a problem in the past.

If you need to know the exact PCI controller I can get that for you.
Comment 6 Christopher Brown 2007-09-16 15:08:57 EDT
(In reply to comment #5)

> If you need to know the exact PCI controller I can get that for you.

That'd be great, try:

lspci -vvxx

and attach this. I've re-assigned this to the PATA maintainer, Alan Cox, who I
*think* is the best person to look at it (apologies for the noise if not).

I'm also adding this as an Fedora 8 blocker since obviously it will prevent you
installing that should you wish to do so.

Cheers
Chris
Comment 7 John Dennis 2007-09-17 11:25:40 EDT
Created attachment 197551 [details]
output of lscpi
Comment 8 Alan Cox 2007-09-18 05:00:45 EDT
Thanks. The FC7 pdc202xx_old (for 2026x hardware) is somewhat updated since FC7
and some stuff got fixed. I'll do some further crosschecking on old 262 stuff.
Its the first 20262 report I've seen but then its such ancient h/w that may not
prove anything
Comment 9 Ian Waring 2007-09-23 08:42:48 EDT
Created attachment 203421 [details]
Output from lspci -vvxx
Comment 10 Ian Waring 2007-09-23 08:43:31 EDT
Created attachment 203431 [details]
Output from dmesg
Comment 11 Ian Waring 2007-09-23 08:48:16 EDT
Think I have the same issue - initial install of Fedora 7 fails with a hang
after displaying "Loading pata_serverworks driver...". This on a Dell PowerEdge
600SC which has worked with every Fedora release FC1-FC6. lspci and dmesg
contents attached.

My first bugzilla post, so if this isn't the appropriate place to log this, i'd
appreciate the feedback.
Comment 12 Chuck Ebbert 2007-10-17 15:47:24 EDT
Respins of Fedora 7 are available:

http://spins.fedoraunity.org/spins
Comment 13 Ian Waring 2007-10-21 06:12:04 EDT
Latest Unity Spin does not solve the problem - on boot from DVD, server hangs at
the stage of "Loading Pata_Serverworks Driver".

If there's any other data I can supply to help fix this, i'd really appreciate
it. Priority of the bug is set to "low" but my life is stuck on FC6 pending a
fix or guidance on how to move things forward...

Ian W.
Comment 14 Ian Waring 2007-10-21 16:13:47 EDT
For what it's worth, Ubuntu Fiesty Fawn seems to have a problem (various forums
report) with the same PATA DVD-RW drive i'm using - which is a NEC ND-3500AG.
Just going to check the Master/Slave/Channel Select jumper settings on the IDE
cables of my Dell 600SC to see if that makes a difference.

The BIOS can see the DVD drive but not the 48x CD-ROM drive that is cabled
downstream...

Ian W.
Comment 15 Will Woods 2007-10-24 12:08:01 EDT
I'm removing this from the F8KernelBlocker list - the hardware is rare and old
enough that we can't slip the release for it. 

Alan, is there an appropriate blocker bug for stuff we're hoping to fix in F8
updates?
Comment 16 Alan Cox 2007-10-24 13:11:32 EDT
I don't have any clear pdc202xx bugs left so hopefully its sorted. I note the
report about FC8 relates to pata_serverworks - which is something else odd as
that code hasnt change for months.
Comment 17 Ian Waring 2007-10-24 15:05:09 EDT
I'll wait for Fedora 8 to release - and will log a new bug report if it's still
not working at that stage. I've not managed to install F7 since it first came
out, which is many months ago now. Looks like i'm far from alone with having a
DVD-RW equipped machine hanging when you try to install F7 off the DVD - at
exactly the same place. However, i'll be patient :-)

Thanks for all your assistance.
Comment 18 Alan Cox 2007-10-24 15:52:20 EDT
Thanks for the info you've provided - I'll keep an eye on the bug and hopefully
F8 will provide either a fix or clues
Comment 19 Ian Waring 2007-11-11 07:08:24 EST
For what it's worth, F8 doesn't work either. Same bug - system boots off DVD,
then  stalls with "Loading pata_serverworks driver..." on the screen. Exactly
the same as F7. Worked fine FC1 though FC6. Looks like i'm stuck at FC6 :-(

The DVD-RW drive in question is a NEC ND3500AG which at the time I bought it
(April 2005) had a stellar reputation. Continues to work fine on FC6 (used it to
burn both the F7 and the F8 DVD ISOs), but no luck since.

Think i'll poll the Fedora support forums to see if anyone else has an issue
with the same drive on F7 or F8. In the meantime, any guidance on what I can do
to help isolate the root cause would be greatly appreciated.

Ian W.
Computacenter plc.
Comment 20 Alan Cox 2007-11-11 07:53:24 EST
Looks related to "Krzysztof Oledzki <olel@ans.pl>' on kernel list
"pata_serverworks hangs"

Ok first things to try

boot the FC8 install image with the option libata.dma=0

also would be interested to know if it boots with the CD attached to a different
port if possible ?
Comment 21 Ian Waring 2007-11-11 11:08:23 EST
Thankyou Krzysztof,

boot with libdata.dma=0 got me past the driver load issue. However, after
picking the language options and saying I was installing from a CD or DVD, it
couldn't find the image on the DVD. Just spat out the CD tray underneath and
refuses to look at the DVD drive.

FWIW, the DVD-RW drive is a NEC ND-3500AG and the CD drive below it is the unit
that came with the machine - the BIOS says its a GCR-8483B (whatever that is).

I'll try switching the DVD drive IDE connections around a bit later tonight (UK
time).

Ian W.
Comment 22 Ian Waring 2007-11-11 11:33:51 EST
I got into an infinite loop - won't read the DVD, just kept spitting out the CD
tray - so I just forced a reboot. Now it's inferring it's doing "first time
boots" and the DVD drive is nowhere to be seen when FC6 boots up - not even on
showing the Places/Computer in Gnome now :-(

Any ideas how I get it back?
Comment 23 Alan Cox 2007-11-11 15:16:59 EST
Sounds like your CD drive firmware crashed, in which case a power cycle should
restore it. Drives can get themselves confused enough to need a power cycle .
Comment 24 Ian Waring 2007-11-12 01:32:16 EST
All fixed now - and i'm running Fedora 8 successfully (which is very impressive
- things come on leaps and bounds every release - but I digress).

The Dell PowerEdge 600SC has three IDE connectors on the motherboard; the
primary connects to the 80GB hard disk shipped with the unit, the secondary has
no connection, and the tertiary connector originally had just a CGR-838B CD
Reader hooked up with Cable Select jumpered. I subsequently added an NEC
ND-3500AG DVD-RW drive, also jumpered Cable Select, which daisy chained into the
same cable Dell provided (it had two connectors around 50mm apart at the end -
looked to be designed for this purpose). This config worked for FC1 through FC6
without problems.

I moved the DVD/CD cable at the motherboard end from the tertiary connector to
the second connector, and on restart with the F8 DVD in the DVD drive, this got
me to the same stage as i'd experienced when i'd tried booting with
libdata.dma=0 set earlier - with the OS on the DVD running, accepting the
language and keyboard setting, then getting stuck in a loop saying it couldn't
see a CD with Fedora on it. On each retry, it kept opening the CD tray, and
didn't seem to be looking at the DVD at all.

On the third loop, I manually opened the DVD tray, pressed the button to let it
close again and hit return on the keyboard at the same time. This time it
spotted the DVD drive, and the installation ran to completion from there.

So, for me, all fixed now, though i'd be sorely tempted to put the CD and DVD
drives on different IDE connectors, or to run them Master/Slave rather than
Cable Select if I had problems in the future.

The issue I had was a regression between FC6 and F7, but I trust the above will
give some clues just in case there were a few thousand folks like me haven't
been able to move up from FC6 yet.

Thankyou for everyone's help and guidance. It is greatly appreciated.

Ian W.
Comment 25 Christopher Brown 2007-12-13 12:15:36 EST
Thanks for the awesome feedback on your issue Ian. It would be good to get
feedback from the original reporter about this issue before possibly closing. John?
Comment 26 Alan Cox 2008-01-14 07:00:58 EST
John: Can you try your promise problem (the original bug before Ian's) with two
things

mem=4095M (if you have < 4GB)

and 

edd=off

EDD is known to be funky on some 20262/20263 firmware, not sure if that is a
problem.
Comment 27 John Dennis 2008-01-14 09:37:59 EST
Re comment 26, yes I'll try it, but it might be a while before I can because the
box in question has now been physically relocated and I only have access to it
on an intermittent basis.
Comment 28 Bug Zapper 2008-05-14 08:55:54 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 29 Bug Zapper 2008-06-16 21:30:38 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.