Bug 243444 - ccs_get should handle xpath queries correctly
Summary: ccs_get should handle xpath queries correctly
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Ryan O'Hara
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 18:21 UTC by Ryan O'Hara
Modified: 2009-04-16 22:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 15:11:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ryan O'Hara 2007-06-08 18:21:17 UTC
ccs_get should be able to process more robust xpath queries, eg. boolean and
count queries. Currently ccs_get is only capable of handling simple queries that
retrieve a value. It would be useful if ccs_get was capable of processing other
types of queries.

ccs should examine the query result type and make the appropriate conversion.
The interface for ccs_get shouldn't change, ie. all result should be returned as
a string.

Comment 2 Ryan O'Hara 2008-04-07 15:11:58 UTC
Going to close this since it seems ccs will be phased out. Not critical to fix.


Note You need to log in before you can comment on or make changes to this bug.