Bug 243468 - Yum updates fail with apache proxy
Yum updates fail with apache proxy
Status: CLOSED DUPLICATE of bug 239034
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
Depends On:
  Show dependency treegraph
Reported: 2007-06-08 17:14 EDT by Dave Fogarty
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-02 11:54:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Fogarty 2007-06-08 17:14:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20070603 Fedora/ Firefox/

Description of problem:
Yum has worked fine for me when setting httpProxy= to our squid proxy, but when I point it at an apache proxy (httpd-2.0.52-32.ent on RHEL4) it fails.  

[root@brick rhn]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5 (Tikanga)
[root@brick rhn]# yum -d 10 check-update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Running "config" handler for "installonlyn" plugin
Running "init" handler for "rhnplugin" plugin
Yum Version: 3.0.1
COMMAND: yum -d 10
Installroot: /
Setting up repositories
Error: Cannot open/read repomd.xml file for repository: rhel-i386-server-5

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Edit /etc/sysconfig/rhn/up2date
2. set enableProxy=1
3. set httpProxy=<some apache proxy>

Actual Results:

Expected Results:

Additional info:
Comment 6 RHEL Product and Program Management 2007-10-15 23:58:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 7 Red Hat Bugzilla 2007-10-25 20:52:24 EDT
User jslagle@redhat.com's account has been closed
Comment 8 Clifford Perry 2007-11-02 11:54:56 EDT

*** This bug has been marked as a duplicate of 239034 ***

Note You need to log in before you can comment on or make changes to this bug.