Bug 24347 - !glibc-2.2-12.i386.rpm unable to Upgrade!
Summary: !glibc-2.2-12.i386.rpm unable to Upgrade!
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-19 10:21 UTC by Need Real Name
Modified: 2016-11-24 15:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 10:22:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-01-19 10:21:06 UTC
Hello, i tried to upgrade from glibc-2.1.92-14 to glibc-2.2-12.
I downloadet the following files from updates.redhat.com
___________________________________
glibc-2.2-12.i386.rpm              |
glibc-common-2.2-12.i386.rpm       |
glibc-devel-2.2-12.i386.rpm        |
glibc-profile-2.2-12.i386.rpm      |
libstdc++-2.96-69.i386.rpm         |
stunnel-3.10-2.i386.rpm            |
___________________________________|

all fine then i done:
rpm -Fvh glibc-profile-2.2-12.i386.rpm !ok!
rpm -Fvh libstdc++-2.96-69.i386.rpm !ok!
rpm -Fvh nscd-2.2-12.i386.rpm !ok!
rpm -Fvh stunnel-3.10-2.i386.rpm !ok!
rpm -Fvh glibc-common-2.2-12.i386.rpm !ok!
rpm -Fvh glibc-devel-2.2-12.i386.rpm !error: failed dependencies: glibc = 
2.2 is needed by glibc-devel-2.2-12!
rpm -Fvh glibc-2.2-12.i386.rpm !error: failed dependencies: glibc-common = 
2.2 is needed by glibc-2.2-12 /usr/bin/getent   is needed by stunnel-3.10-
2!
but i have installed glibc-common-2.2-12.i386.rpm !!

what is wrong here, i dont understand, please help me out

Sincerly Markus Lanthaler

rpm -Fvh glibc-2.2-12.i386.rpm

Comment 1 Jakub Jelinek 2001-01-19 10:25:25 UTC
If you read e.g. the errata page for glibc, it mentions you have to
rpm -Uvh glibc-2.2-12.i386.rpm glibc-common-2.2-12.i386.rpm
and then do the usual -Fvh stuff. That's because glibc was split into two
subpackages and the intent is to require both to be installed at once.
The reason why it was split is to save space: glibc-common is only i386 while
glibc is i386 and i686 (similarly for other arches).


Note You need to log in before you can comment on or make changes to this bug.