Bug 243478 - Should libgnomeui require yelp for gnome-help API?
Should libgnomeui require yelp for gnome-help API?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeui (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: 243378 243397
  Show dependency treegraph
 
Reported: 2007-06-08 17:49 EDT by Toshio Kuratomi
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 18:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Kuratomi 2007-06-08 17:49:36 EDT
Description of problem:

Gnome provides a gnome-help API to open a help browser on help files provided by
applications.  The current browser capable of viewing these files is yelp. 
Should libgnomeui

  Require: yelp

so that the applications that call the API get help files?  Should the
individual apps?  Or should we just ignore the issue?

Transcript of IRC discussion:

(01:06:31 PM) abadger1999_: Anyone know/have an opinion whether individual apps
should Require: yelp in fedora packages?
(01:07:05 PM) mclasen: might make more sense to put the yelp dependency in libgnome
(01:07:17 PM) mclasen: since apps use libgnome api to start the help browser

(01:16:08 PM) halfline: well libgnomeui not libgnome
(01:20:20 PM) abadger1999_: halfline: Even though libgnome is the app that
provides the help API?
(01:20:26 PM) abadger1999_: s/app/library/

(01:31:28 PM) halfline: i don't know.  i mean libgnome is supposed to have non-X
stuff in it.  Making it require an X program seems a little weird
(01:32:21 PM) halfline: although we ship gnome-open in libgnome
(01:32:23 PM) halfline: so whatever
(01:38:00 PM) abadger1999_: halfline: That's true.  let's see how gnome-open
works....
(02:08:06 PM) abadger1999_: It looks like we currently ignore the issue. 
gnome-open is shipped with libgnome but there's no dependencies to ensure it has
any applications that can open help, http:// urls, etc.
(02:37:21 PM) davidz: abadger1999: I think that's because it's configurable in
preferred applications
Comment 1 Matěj Cepl 2007-06-08 18:19:50 EDT
Oh well, I thought I have discussed this with mclasen in advance. Whatever, the
original "Package should require yelp for its help" was made into these bugs:

243327 243328 243329 243330 243331 243332 243333 243334 243335 243336 243337
243338 243339 243340 243341 243342 243343 243344 243345 243346 243347 243348
243349 243350 243351 243352 243353 243354 243355 243356 243357 243358 243359
243360 243361 243362 243363 243364 243365 243366 243367 243368 243369 243370
243371 243372 243373 243375 243376 243377 243378 243379 243380 243381 243382
243383 243384 243385 243386 243387 243388 243389 243390 243391 243392 243393
243394 243395 243396 243397 243398 243399 243400 243401 243402 243403 243404
243405 243406 243407 243408 243410 243411 243412 243413 243414 243415 243416
243417 243469 243472 243473
Comment 2 Matěj Cepl 2007-06-08 18:24:53 EDT
And probably also that components affected were 

agave anjuta balsa control-center dasher deskbar-applet dia drivel ekiga eog
epiphany epiphany-extensions evince evolutionfast-user-switch-applet
fedora-release-notes file-roller fryskf-spot galeon gcalctool gcompris
gconf-editor gdm gedit ghexgchempaint glabels glade2 glipper glom glunarclock
gnochmgnome-applet-netspeed gnome-applets gnome-applet-sensorsgnome-applet-timer
gnome-applet-vm gnomebaker gnome-commandergnome-desktop gnome-doc-utils
gnome-games geniusgnome-keyring-manager gnome-media gnome-netstatus
gnome-nettoolgnome-panel gnome-pilot gnome-power-manager
gnomeradiognome-schedule gnomesword gnome-system-monitor
gnome-terminalgnome-translate gnome-user-docs gnome-utils gnotime gnumeric
gokgossip gramps grhino grip gthumb gtk-doc gtranslator gucharmap
jokosher lat linphone lock-keys-applet mail-notification meld
monkey-bubble planner pybliographer qalculate-gtk rhythmbox
scigraphica scribes seahorse sound-juicer synaptic tomboy totem
usbsink virt-manager xchat-gnome zenity
Comment 3 Toshio Kuratomi 2007-06-14 14:51:46 EDT
Hi Ray,

I see you added Requires: yelp to Rawhide libgnomeui.  If that's the final
decision feel free to close this bug :-)

Note You need to log in before you can comment on or make changes to this bug.