Bug 243483 - multipath tools needs static path prio callouts for initramfs
multipath tools needs static path prio callouts for initramfs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.0
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Ben Marzinski
Corey Marthaler
:
: 244851 (view as bug list)
Depends On:
Blocks: 185852
  Show dependency treegraph
 
Reported: 2007-06-08 18:57 EDT by Bryn M. Reeves
Modified: 2010-10-22 11:34 EDT (History)
13 users (show)

See Also:
Fixed In Version: RHEA-2007-0531
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:47:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add .static versions of prio checkers (2.97 KB, patch)
2007-06-08 18:57 EDT, Bryn M. Reeves
no flags Details | Diff

  None (edit)
Description Bryn M. Reeves 2007-06-08 18:57:23 EDT
Description of problem:
The multipath command may need to run path priority callouts to configure
multipath maps at boot up time. This requires statically linked versions of the
commands.

Version-Release number of selected component (if applicable):
0.4.7-8.el5

How reproducible:
100%

Steps to Reproduce:
1. ldd /sbin/mpath_prio_*
  
Actual results:
/sbin/mpath_prio_alua:
        libc.so.6 => /lib64/libc.so.6 (0x000000362d200000)
        /lib64/ld-linux-x86-64.so.2 (0x000000362ce00000)
/sbin/mpath_prio_emc:
        libc.so.6 => /lib64/libc.so.6 (0x000000362d200000)
        /lib64/ld-linux-x86-64.so.2 (0x000000362ce00000)
/sbin/mpath_prio_hds_modular:
        libc.so.6 => /lib64/libc.so.6 (0x000000362d200000)
        /lib64/ld-linux-x86-64.so.2 (0x000000362ce00000)
/sbin/mpath_prio_netapp:
        libc.so.6 => /lib64/libc.so.6 (0x000000362d200000)
        /lib64/ld-linux-x86-64.so.2 (0x000000362ce00000)
/sbin/mpath_prio_tpc:
        libc.so.6 => /lib64/libc.so.6 (0x000000362d200000)
        /lib64/ld-linux-x86-64.so.2 (0x000000362ce00000)


Expected results:
# ldd /sbin/mpath_prio_* 
/sbin/mpath_prio_alua:
        libc.so.6 => /lib64/libc.so.6 (0x000000362d200000)
        /lib64/ld-linux-x86-64.so.2 (0x000000362ce00000)
/sbin/mpath_prio_alua.static:
        not a dynamic executable
/sbin/mpath_prio_emc:
        libc.so.6 => /lib64/libc.so.6 (0x000000362d200000)
        /lib64/ld-linux-x86-64.so.2 (0x000000362ce00000)
/sbin/mpath_prio_emc.static:
        not a dynamic executable
[...]

Or:
/sbin/mpath_prio_alua:
        not a dynamic executable
/sbin/mpath_prio_emc.static:
        not a dynamic executable
[...]

Additional info:
Comment 1 Bryn M. Reeves 2007-06-08 18:57:23 EDT
Created attachment 156625 [details]
patch to add .static versions of prio checkers
Comment 2 Bryn M. Reeves 2007-06-08 19:05:08 EDT
Ben, the patch in comment #1 adds an extra .static version for each command,
like the existing multipath.static. It's a trivial change to mkinitrd if you'd
prefer to just build the regular commands statically though (this is what udev
does now for scsi_id etc).
Comment 3 RHEL Product and Program Management 2007-06-08 19:23:37 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Ben Marzinski 2007-06-12 12:25:42 EDT
Has this actually caused any errors? Because according to bz #234928, the there
shouldn't be a need for any static packages, and I'd rather not bloat initramfs
unnecessarily.  If initramfs starts scanning for multipath devices, and
dynamically building them, it will need to include every prio callout program.
I'm going to look into this myself, but I'd like to know if you have actually
seen any errors.
Comment 5 Bryn M. Reeves 2007-06-12 13:52:06 EDT
Still a need for RHEL5 and earlier - F7 onwards are including libc in the
initramfs so we'll need to drop the .static versions for those packages.
Comment 6 Ben Marzinski 2007-06-15 17:03:54 EDT
Patch applied, thanks.
Comment 8 Ben Marzinski 2007-06-19 17:08:05 EDT
*** Bug 244851 has been marked as a duplicate of this bug. ***
Comment 15 errata-xmlrpc 2007-11-07 11:47:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0531.html

Note You need to log in before you can comment on or make changes to this bug.