Bug 243490 - grub fails on FS with 512-byte inodes
grub fails on FS with 512-byte inodes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
:
Depends On:
Blocks: 205161
  Show dependency treegraph
 
Reported: 2007-06-08 20:44 EDT by Bill Nottingham
Modified: 2014-03-16 23:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 14:05:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
untested patch (4.35 KB, patch)
2007-08-02 17:23 EDT, Eric Sandeen
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2007-06-08 20:44:09 EDT
Description of problem:

ext3 lets you change the size of the inode. This is useful for keeping extended
attributes in-inode (see bug #205161 for some 'interesting' fun when they're not
in-inode).

However, if you do this, grub chokes, and fails to properly install.

grub-install errors with:

The file /boot/grub/stage1 not read correctly.

Version-Release number of selected component (if applicable):

grub-0.97-13

Additional info:

The message not proper english.
Comment 1 Bill Nottingham 2007-06-08 20:49:56 EDT
If you boot,you are dropped to the grub prompt. Attempting to read the FS yields
"Error 2: Bad file or directory type"
Comment 2 Bill Nottingham 2007-06-08 21:14:20 EDT
Looking briefly at the code, this seems to be 'expected' from the way it's
written. Ugh.
Comment 3 Eric Sandeen 2007-08-02 10:48:34 EDT
Oh... bummer.  Workaround would be to have a separate /boot of course, if
further 512-byte inode testing was desired.  I suppose grub needs to be told
about this new format.  I'll see if I can take a look...
Comment 4 Eric Sandeen 2007-08-02 17:23:15 EDT
Created attachment 160552 [details]
untested patch

Grub is using sizeof(struct ext2_inode) to calculate inode offsets in the inode
table.	Looking at the inode size in the superblock instead should fix this. 
Attached patch builds but is untested.
Comment 5 Eric Sandeen 2007-08-13 14:05:15 EDT
patch in comment #4 has been tested, is in devel/ now.  Thanks pjones!


Note You need to log in before you can comment on or make changes to this bug.