Bug 243510 - wlassistant can't connect to wpa encrypted network
wlassistant can't connect to wpa encrypted network
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: wlassistant (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 06:04 EDT by Martin Jürgens
Modified: 2008-04-01 11:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 11:15:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2007-06-09 06:04:13 EDT
Description of problem:
wlassistant can't connect to wpa encrypted network

Version-Release number of selected component (if applicable):


How reproducible:
Every Time.

Steps to Reproduce:
1. Open wlassistant
2. Connect to wpa encrypted network
3.
  
Actual results:
Failed appears, Terminal says:

ACTION: CONNECT.
Running DHCP client found.
kill_dhcp: /sbin/dhclient -r ath0
No pre-connection command specified.
iwconfig_set: /sbin/iwconfig ath0 mode managed channel 11 key off essid Nywag
iwconfig_ap: /sbin/iwconfig ath0 ap 00:04:0E:7A:29:E5
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or
directory
Using wpa_supplicant driver: wext
WPA client started. Waiting for status...
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or
directory
CONNECTION FAILED.


Expected results:
Should connect ;)

Additional info:
Comment 1 Gianluca Varisco 2007-06-17 07:49:55 EDT
Have you already tried to install NetworkManager and use it (knetworkmanager is
the KDE front-end) instead? Support for Intel 3945, rt2x00 and zd1211 based
devices among others. It also supports:

* Wired Ethernet Devices (IEEE 802.3)
* Wireless Ethernet Devices (IEEE 802.11): Unencrypted, WEP, WPA Personal, WPA
Enterprise
* Virtual Private Network (VPN): OpenVPN, VPNC
* Dial-Up (PPP) 

According to the F7 official FAQ: "the plan for Fedora 8 is to more deeply
integrate Network Manager throughout the distribution and enable it by default
in all instances".

Comment 2 Martin Jürgens 2007-06-17 08:01:17 EDT
Thanks, I use NetworkManager already.

But I wanted to connect with wlassistant and that sadly did not work to a WPA
protected network.
Comment 3 Tom "spot" Callaway 2007-11-19 08:26:06 EST
Are you using madwifi? I don't think that wlassistant knows how to handle
passing the right driver to wpa_supplicant in the madwifi case.
Comment 4 Mo Morsi 2008-01-12 16:17:44 EST
I am running into the same problem w/ wlassistant. Both wlassistant and Network
manager can detect the networks but neither can connect to them. NewtorkManager
will spin for a while upon network selection, then will prompt me to enter the
password (WPA/TKIP/Preshared) (which is already located in the keyring), then
just stop (no connection). wlassistant gives the exact same output as that of
the original poster. Wireless worked flawlessly on Fedora 7 as described in my
blog post here (http://mohammed.morsi.org/blog/?q=node/218). Full diagnosis and
relevant command output can be found in my FedoraForumn inquiry here
(http://forums.fedoraforum.org/showpost.php?p=941955&postcount=9)
Comment 5 Martin Jürgens 2008-01-13 05:41:31 EST
Mohammed, I can successfully connect to my WPA + WPA2 network using my broadcom
chip + NetworkManager but I did not try wlassistant again.

I have the following ideas: Can you check if you have the latest f8 updates? You
could also try to remove the Broadcom Firmware in /lib/firmware and re-extract it.
Comment 6 Martin Jürgens 2008-01-13 05:46:47 EST
Ah and by the way, try not to use ndiswrapper but use the bcm43 driver
completly, instead: Remove ndiswrapper, kmod-ndiswrapper and the line you added
to /etc/rc.local. After, eventually re-extract the firmware and reboot.

The bcm43 linux driver really works *very* well (as well as the madwifi driver)
in F8. If you still have to use that ndiswrapper trick, you should maybe report
a bug against Fedora saying that your WLAN chip does not work properly. Also
attach dmesg output.
Comment 7 Tom "spot" Callaway 2008-03-11 10:47:03 EDT
Martin, can you reproduce this with the bcm43 driver (not madwifi)? I don't have
ready access to a WPA enabled network.
Comment 8 Tom "spot" Callaway 2008-04-01 11:15:03 EDT
I'm closing this out, feel free to reopen if you can reproduce this with bcm43.

Note You need to log in before you can comment on or make changes to this bug.