Bug 243512 - SELinux is preventing /usr/sbin/useradd (useradd_t) "read write" to faillog (var_log_t).
SELinux is preventing /usr/sbin/useradd (useradd_t) "read write" to faillog (...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 06:14 EDT by Martin Jürgens
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 07:16:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
selinux alert (2.29 KB, text/plain)
2007-06-09 06:14 EDT, Martin Jürgens
no flags Details

  None (edit)
Description Martin Jürgens 2007-06-09 06:14:13 EDT
Description of problem:
When installing BackupPC with yum, SELinux blocks something:

SELinux is preventing /usr/sbin/useradd (useradd_t) "read write" to faillog
    (var_log_t).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install BackupPC
2.
3.
  
Actual results:
SELinux warning

Expected results:
Nothing

Additional info:
Comment 1 Martin Jürgens 2007-06-09 06:14:14 EDT
Created attachment 156640 [details]
selinux alert
Comment 2 Peter Vrabec 2007-06-11 04:43:15 EDT
I can't reproduce it, but my context on /var/log/faillog is 
-rw-------  root root system_u:object_r:faillog_t      /var/log/faillog

Martin, could you run:
#restorecon /var/log/faillog
and see if context changed.
Comment 3 Martin Jürgens 2007-06-11 07:16:12 EDT
Just uninstalled it and installed it again, no error message.

Don't ask me what was wrong. I am going to reopen this bug if it reappears.
Comment 4 Daniel Walsh 2007-06-11 10:33:32 EDT
There is a knoqn problem on initial installs and upgrades of the faillog file
getting the wrong context.  This should be fixed on upgrades going forward. 
restorecon -R -v /var/log should fix the problem.

Note You need to log in before you can comment on or make changes to this bug.