This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 243523 - arm architecture support
arm architecture support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
rawhide
arm9 Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2007-06-09 08:00 EDT by Lennert Buytenhek
Modified: 2009-09-21 17:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 14:37:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for redhat-rpm-config 8.0.45-16.fc8. (1.50 KB, patch)
2007-06-09 08:00 EDT, Lennert Buytenhek
no flags Details | Diff

  None (edit)
Description Lennert Buytenhek 2007-06-09 08:00:07 EDT
There are three issues with the current redhat-rpm-config package on
ARM systems:

1. The copy of config.guess in redhat-rpm-config always reports
   *-unknown-*-*, even if we are running on a Fedora ARM install,
   and it always reports -gnu even if we are running on an ARM
   system that uses EABI, where the upstream convention (followed
   by upstream binutils, gcc, glibc) is to use -gnueabi.

2. redhat-rpm-config's rpmrc file doesn't have optflags defines for
   any of the more modern arm architecture generations.

3. redhat-rpm-config's macros file unconditionally defines %_gnu as
   -gnu, overriding any previous declaration of that macro in rpm's
   macros file or in the platform's macros file.  On ARM EABI systems,
   we have %{_gnu} defined as -gnueabi in the platform macros files,
   but redhat-rpm-config's macros file sets this back to -gnu.

The attached patch fixes these issues, and produces a redhat-rpm-config
package that works fine on arm.  The first two issues are solved in a
supposedly uncontroversial way, but the solution for the third might be
a bit controversial: since the previous macros files already define
%{_gnu}, I simply deleted the %{_gnu} define from redhat-rpm-config's
macros file.

Comments?
Comment 1 Lennert Buytenhek 2007-06-09 08:00:07 EDT
Created attachment 156645 [details]
Patch for redhat-rpm-config 8.0.45-16.fc8.
Comment 2 Jeremy Katz 2007-06-19 14:37:42 EDT
Looks good; applied

Note You need to log in before you can comment on or make changes to this bug.