Bug 243532 - mpath volumes in /etc/fstab should use names instead of labels
mpath volumes in /etc/fstab should use names instead of labels
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 185852
  Show dependency treegraph
 
Reported: 2007-06-09 10:31 EDT by Bryn M. Reeves
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0644
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:21:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2007-06-09 10:31:39 EDT
Description of problem:
Anaconda configures multipath volumes in /etc/fstab to use mount-by-label. This
can cause boot problems when individual paths are visible in /dev. The same
problem can happen with LVM & MD devices if labels are used - anaconda uses the
real device name in these cases as the naming is persistent. Need to do the same
thing for multipath.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.36

How reproducible:
100%

Steps to Reproduce:
1. Install a multipath system using "linux mpath"
2. Create some file systems directly on mpath partitions
3. Reboot & check /etc/fstab
  
Actual results:
Boot fails at file system check due to duplicate labels.

The installed /etc/fstab contains, for e.g.:

LABEL=/boot        /boot    ext3     defaults 1 2

Expected results:
System boots correctly.

The installed /etc/fstab contains, for e.g.:

/dev/mpath/mpath0p1        /boot    ext3     defaults 1 2
Comment 3 Jun'ichi NOMURA 2007-06-14 23:28:06 EDT
Not using label might be a solution.

But there is another solution: modifying e2fsprogs and others
to understand the stacked device.
A patch for e2fsprogs is provided in this BZ (comment#19):
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=156324

Comment 4 Bryn M. Reeves 2007-06-15 04:22:11 EDT
I think this is probably a better way of doing it, but it's mount that needs to
understand the stacked devices - in RHEL5 it's provided by util-linux.

Seems this would increase the number of packages that need to be touched for
this feature when we're already on a fairly tight schedule.
Comment 5 David Cantrell 2007-06-18 14:23:11 EDT
Anaconda now writes /dev/mpath* names to /etc/fstab even if there is a
filesystem label.  Moving state to modified.
Comment 6 RHEL Product and Program Management 2007-06-18 14:24:48 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 errata-xmlrpc 2007-11-07 12:21:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0644.html

Note You need to log in before you can comment on or make changes to this bug.