Bug 243534 - Strace hangs system
Strace hangs system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 11:00 EDT by Tim Niemueller
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 03:33:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Niemueller 2007-06-09 11:00:16 EDT
Description of problem:
I tried to strace nm-vpn-properties to see why vpnc could not be loaded, this
made my system (Thinkpad T60, Core 2 Duo) freeze. I could still move the mouse
cursor, but the machine would not react to clicks or keyboard input, the clock
in the panel stops.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3219.fc7
kernel-2.6.21-1.3224.fc7
strace-4.5.15-1.fc7


How reproducible:
Always

Steps to Reproduce:
1. strace nm-vpn-properties
2. See system freeze
  
Actual results:
System freezes

Expected results:
strace output of process.

Additional info:
I have tested both mentioned kernels, the freeze seems to happen at different
times in the running strace (the last strace output was different on several tries).
Comment 1 Roland McGrath 2007-08-02 01:44:30 EDT
Can you reproduce this with a more recent F7 update kernel?
Comment 2 Tim Niemueller 2007-08-03 06:59:22 EDT
Yes, I have just tried it and it still happens, versions:

# rpm -q kernel strace
kernel-2.6.22.1-29.fc7
kernel-2.6.22.1-41.fc7
strace-4.5.15-1.fc7

Kernel 2.6.22.1-41.fc7 is currently running. The last console output was a call
to poll().
Comment 3 Roland McGrath 2007-09-10 03:33:12 EDT
I think I reproduced what you saw, but I didn't see any evidence of any
system-wide bug.  That is, the whole X session did indeed stop responding so
that only the X server itself responded (mouse movement, hot keys to switch
VTs).  The system overall was fine, and I was able to use it remotely or from
another VT no problem.  From there I saw strace blocked in doing output to its
stdout, i.e. the pty to the gnome-terminal in my X session.  I imagine that
nm-vpn-properties is in the middle of some X operation that grabs the server or
something or other.  As soon as nm-vpn-properties resumes running, everything
updates normally (and even processes some mouse clicks I did while it was
"frozen").  But strace won't let nm-vpn-properties resume until it finishes
writing to stdout; that write call is blocked waiting for gnome-terminal to read
from the pty; gnome-terminal is blocked waiting for the X server; the X server
is not responding because nm-vpn-properties is in the middle of something.  So,
deadlock.

Using "strace -o log nm-vpn-properties", nothing funny happens.

Note You need to log in before you can comment on or make changes to this bug.