Bug 243546 - Enabling "software sound mixing" causes Gnome to freeze when logging in
Summary: Enabling "software sound mixing" causes Gnome to freeze when logging in
Status: CLOSED DUPLICATE of bug 238680
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-audio (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-09 16:45 UTC by Thomas Pifer
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 09:15:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Pifer 2007-06-09 16:45:28 UTC
Description of problem:
Enabling "software sound mixing (ESD)" in sound preferences causes further
log-ins to freeze/halt Gnome from logging in.

Version-Release number of selected component (if applicable):


How reproducible:
About 75% of the time: Occasionally, once this happens, the next log-in will
succeed.   

Steps to Reproduce:
1. Head to System > Prefrences > Hardware > Sound
2. Go the Sound tab, and check "Enable software sound mixing (ESD)" and "Play
system sounds"
3. Log-out, then back in.
  
Actual results:
You should either end up with a desktop with only the desktop background or with
empty panels (You cannot right-click them to add new ones), both cases have no
desktop icons either.  You need to kill the X server (Ctrl + alt + Backspace) in
order to log-out.


Expected results:
Gnome starts-up as normal.

Additional info:
This occurs on both fresh, and upgraded installs of Fedora 7, both with and
without updates installed (Does not happen in FC6).

Comment 1 John Conroy 2007-06-10 22:43:04 UTC
Duplicate of Bug #238680?  Try the following...

edit /etc/esd.conf
change
default_options=
to
default_options=-nobeeps -unix -as 2

Comment 2 Thomas Pifer 2007-06-11 02:42:38 UTC
Yup, fixes the problem, and it looks like a duplicate.

Comment 3 Bastien Nocera 2007-06-11 09:15:37 UTC

*** This bug has been marked as a duplicate of 238680 ***


Note You need to log in before you can comment on or make changes to this bug.