Bug 243581 - Pirut forgets dependencies if dep dialog canceled
Pirut forgets dependencies if dep dialog canceled
Status: CLOSED DUPLICATE of bug 242368
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2007-06-09 23:49 EDT by Jason Farrell
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-13 13:59:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2007-06-09 23:49:02 EDT
Description of problem:
Pirut fails to install dependencies if you Cancel out of the "Dependencies
added" dialog. I rarely use the GUI utils, and I got bit when I did. I tried to
"GO BACK" to install more packages, but discovered that each time you cancel the
dependency dialog it forgets the previous depcheck list for your selected
packages and only calculates a deplist for the new selection, but then proceeds
to install without deps anyway. I imagine that a LOT of people have been bit by

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run pirut
2. find an app to install which includes some deps which are not already
installed on your system. for this example: "apollon" depends on "gift", so yum
remove both if they're already installed, then select only "apollon" for install.
3. click Apply
4. click Continue in the 'Package selections' dialog
5. click Cancel in the 'Dependencies added' dialog
6. optionally, choose other apps with or without deps to install.
7. click Apply
8. note that newly calculated deps in the 'Deps added' dialog (if necessary) do
NOT include the deps for the previous apps you selected, but the apps minus deps
are installed anyway.
Actual results:
dependencies are not installed so apps fail in interesting ways, missing libs, etc.

Expected results:
cmdline yum doesn't allow you to force an install without deps (though rpm
does), so pirut *especially* should not.
Comment 1 Otto Rey 2007-06-12 21:12:20 EDT
The same happen if "No more mirrors to try" solving dependencies (go back to
pirut window, press apply again and packages install without needed
dependencies). Why "rpm engine" eat these packages too?
Comment 2 Jeremy Katz 2007-06-13 13:59:26 EDT

*** This bug has been marked as a duplicate of 242368 ***

Note You need to log in before you can comment on or make changes to this bug.