Bug 243586 - dhclient bug prevents starting up networking
dhclient bug prevents starting up networking
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-06-10 04:33 EDT by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-17 16:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-06-10 04:33:47 EDT
Description of problem:

On a Dell Dimension E520 with Intel Core2 Duo CPU and an integrated Intel
82562V 10/100 Network Connection with the e1000 driver on which I have
installed F7 x86_64 the boot process stops at:
'Bringing up interface eth0' and 'Determining IP information for eth0...'
shows a FAILURE and then continues booting. Result no networking.
Trying to '/sbin/ifup eth0' or '/sbin/ifdown eth0' freezes PC and I have to
pull the power plug.
A solution seems to be to 'NOT activate the device when computer starts'
then first delete the file "/var/lib/dhclient/dhclient-eth0.leases" and
only then to '/sbin/ifup eth0'.

Stangely I do not see this bug on a PC with a MSI K8N Neo2 Platinum
mainboard, nVidia nForce3 chipset, AMD64 3500+ CPU and Realtek RTL 8169
ethernet NIC where I have also installed F7 x86_64 so there might be
some hardware/driver connection.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install F7 x86_64 on a DEll Dimension E520 with same components
Actual results:
No networking

Expected results:
IP information collected correctly with result networking

Additional info:
Comment 1 H.Breimer 2007-06-10 09:13:23 EDT
I have a intel board with core2duo and f7-x86_64.
It shows the same behaviour as described above,

Strange is that when I press the reset switch of the computer before the failure
indication, the computer restarts and fully boots with the networking inplace
and doing what it is supposed to do.

My F8 box behaves identical.
Comment 2 David Timms 2007-06-14 19:37:22 EDT
Can you try if the following succeeds in getting networking going again ?:
system network stop
system network start
Comment 3 H.Breimer 2007-06-15 10:05:04 EDT
I can find no "system" command, not in /bin , /sbin , /usr/bin ,
or /usr/sbin.

Pls clarify.
Thks Henk
Comment 4 H.Breimer 2007-06-16 09:18:14 EDT
Thanks for reply. I tried service network stop and service network start as you
suggested. This did not work.

In the mean time I installed kernel 3228 and the updates of june 15.
AND PRESTO, the effects I described earlier have gone. Reboot works through
networking without problems and the system now performs as expected.

Was it dhclient?, kernel or something else? Who knows.
My problem has SOLVED itself.
Comment 5 Need Real Name 2007-06-17 10:20:39 EDT
With the latest updates (kernel-2.6.21-1.3228?)
the problem seems to have been solved and
the network connection is established correctly
at boot.
Comment 6 David Cantrell 2007-06-17 16:23:17 EDT
Reassigning to kernel component and marking as closed rawhide.

Note You need to log in before you can comment on or make changes to this bug.