Bug 243588 - cp gives error when destination is symlink
cp gives error when destination is symlink
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-06-10 04:42 EDT by Michael McLagan
Modified: 2008-06-16 21:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:31:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael McLagan 2007-06-10 04:42:23 EDT
Description of problem:

Previous versions of cp would honour symlinks as the target of a copy. 
coreutils-5.97-12.5.fc6 exhibits the usual, expected behavior.  The version
released with F7 does not, giving an error message instead.  

Version-Release number of selected component (if applicable):

coreutils-6.9-2.fc7.i386.rpm

How reproducible:

always

Steps to Reproduce:
1. cd /var
2. ln -sf beta tmp/alpha
3. echo "blah" > tmp/alpha  (this creates a file called beta with "blah" in it)
4. rm tmp/beta
5. echo "blah" > file
6. cp file tmp/alpha
  
Actual results:

cp: cannot create regular file `tmp/alpha': File exists

Expected results:

[root@localhost var]# dir tmp
total 12
lrwxrwxrwx 1 root     root        4 Jun 10 04:35 alpha -> beta
-rw-r--r-- 1 root     root        5 Jun 10 04:36 beta

Additional info:

Regressing to coreutils-5.97-12.5.fc6 exhibits the correct behavior
Comment 1 Jim Meyering 2007-06-10 09:18:44 EDT
Thanks for the report.  That is indeed a bug.  I've just fixed it upstream:
  http://article.gmane.org/gmane.comp.gnu.core-utils.bugs/10680
Comment 2 Tim Waugh 2007-06-13 09:44:15 EDT
This fix seems to introduce some other problems, reading further in the thread.
 I'm going to defer this bug-fix until F-8, or until a new stable coreutils
release appears with the fix.
Comment 3 Michael McLagan 2007-11-16 16:16:04 EST
As of Fedora 8, coreutils-6.9-9.fc8, cp still does not properly work with the
dangling symlink despite the upstream commentary suggesting that the fix had
been worked out an incorporated into their code.

When will this be brought down into Fedora ?
Comment 4 Jim Meyering 2007-11-16 16:25:00 EST
The existing patch upstream has subtle flaws, and is about to be removed.
I'll post a link here over the weekend.
Comment 5 Jim Meyering 2007-11-22 03:59:50 EST
Here's why GNU cp will (by default) continue to fail to copy through dangling
symlinks:

http://thread.gmane.org/gmane.comp.gnu.coreutils.bugs/11922
Comment 6 Bug Zapper 2008-05-14 08:59:13 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2008-06-16 21:31:53 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.