Bug 243626 - System hangs using Sony Ericsson gc89 pcmcia card
System hangs using Sony Ericsson gc89 pcmcia card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-10 17:29 EDT by Piotr Kral
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 15:24:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci (1.89 KB, text/plain)
2007-06-10 17:29 EDT, Piotr Kral
no flags Details
Output of /var/log/messages after inserting card (1.51 KB, text/plain)
2007-08-02 05:04 EDT, Piotr Kral
no flags Details

  None (edit)
Description Piotr Kral 2007-06-10 17:29:50 EDT
Description of problem:
I id an upgrade form fc6 (x86_64) to f7 (x86_64) on my Thinkpad T60 (output of
lspci in attachment) without the gc89 cart inside. After upgrade I've putted in
the card and reboot computer. System was hanging on sysstat. Without the gc89 it
was working fine (I had some problems with ethernet controller, but that's not
important). When I've put in my card after system startup it wasn't hanging
computer (not always) but I've never been able to establish a connection. The
best case was:
1. insert card  - kernel detect it and gives it /dev/ttyS0 name
2. #setserial /dev/ttyS0 baud_base 460800 - turning on the cad
3. #pppd call connect-iplus
and after a few seconds system hangs
4. Sometimes system hanged earlier, for example on card insertion - either it's
random or I cant see any reasons why it's not olways the same.

Right know I did a full update via yum and eth0 (sysstat was updated) and it
looks like this:
1. System doesn't hangs on sysstat ... but it hangs on haldaemon
2. Any action performed on /dev/ttyS0 (after putting the card in with working
system) done by setserial or pppd (for example "setserial /dev/ttyS0) causes
system to hang
3. When system is hanging and I'll put out the card after 2 -3 seconds makes
hard reboot (it was like that from the beginning)
4. It still hangs sometimes (randomly?) when I just insert the card
5. There is nothing in any logs - system is working fine and suddenly starts to
boot.

Version-Release number of selected component (if applicable):
kernel 2.6.21-1.3194.fc7
sysstat 7.0.4-2.fc7
hal 0.5.9-8.fc7
Comment 1 Piotr Kral 2007-06-10 17:29:50 EDT
Created attachment 156675 [details]
Output of lspci
Comment 2 Piotr Kral 2007-06-14 08:46:51 EDT
Kernel 2.6.21-1.3228.fc7 didn't change anything... Any ideas?
Comment 3 Piotr Kral 2007-08-01 07:17:18 EDT
Kernel 2.6.22.1-41.fc7 didn't change anything either nor the previous ones. I've
installed F7 on different laptop (Asus) witch x86 architecture and the symptoms
ware very similar. Does anyone have these problems?
Comment 4 Chuck Ebbert 2007-08-01 18:03:54 EDT
Is anything written to the system log when the card is inserted?
Is the system really frozen totally? e.g does pressing capslock
turn the light on and off? Does it respond to the sysrq key?

http://en.wikipedia.org/wiki/Magic_SysRq_key

Be sure to enable the key before trying anything
 # echo 1 > /proc/sys/kernel/sysrq

alt-sysrq-p should show where it is stuck if it's looping.

Comment 5 Piotr Kral 2007-08-02 05:04:03 EDT
Created attachment 160506 [details]
Output of /var/log/messages after inserting card

I've created attachment witch output of /var/log/messages. As You can see there
is "usual stuff" and suddenly syslog restarts after I did
#setserial /dev/ttyS0
System is completely  frozen, no capslock, no sysrq, no anyting.
Comment 6 Chuck Ebbert 2007-08-02 18:04:09 EDT
What is in the file /proc/interrupts after inserting the card (but not trying to
use it?)
Comment 7 Piotr Kral 2007-08-03 03:23:53 EDT
$ cat /proc/interrupts
           CPU0       CPU1
  0:    1057434          0   IO-APIC-edge      timer
  1:         22          0   IO-APIC-edge      i8042
  8:          0          0   IO-APIC-edge      rtc0
  9:        464       2096   IO-APIC-fasteoi   acpi
 12:       2333        527   IO-APIC-edge      i8042
 14:       2526          0   IO-APIC-edge      libata
 15:          0          0   IO-APIC-edge      libata
 16:          2      84391   IO-APIC-fasteoi   yenta, uhci_hcd:usb1, fglrx
 17:       2960          0   IO-APIC-fasteoi   uhci_hcd:usb2, HDA Intel
 18:        125      10023   IO-APIC-fasteoi   uhci_hcd:usb3
 19:        241          0   IO-APIC-fasteoi   uhci_hcd:usb4, ehci_hcd:usb5
2297:        472      21964   PCI-MSI-edge      eth0
2298:       8576      27037   PCI-MSI-edge      ahci
NMI:          1          0
LOC:    1057302    1057229
ERR:          0

As I can see the /proc/interrupts didn't change after inserting the card, but
dmesg shows that the card runs in IRQ 16:
ACPI: PCI Interrupt 0000:16:00.1[A] -> GSI 16 (level, low) -> IRQ 16
0000:16:00.1: ttyS0 at I/O 0xa000 (irq = 16) is a 16550A
Comment 8 Chuck Ebbert 2007-08-03 19:09:11 EDT
Serial doesn't claim its interrupt until first use of the port.
Did the gc89 work in FC6?
Comment 9 Piotr Kral 2007-08-03 19:30:23 EDT
Yes it worked fine in FC6. As I mentioned in my first post, the problem started
after upgrade to F7.
Comment 10 Piotr Kral 2007-08-10 08:12:36 EDT
I did an additional check to be 100% sure. I've booted from livve cd's and it
looks like this:
Fedora 7 test4 - runs fine
Ubuntu 7.04 - runs fine
Fedora 7 - hangs...
Comment 11 Chuck Ebbert 2007-08-10 17:07:54 EDT
Try adding "pci=nomsi,nommconf" to the kernel parameters in grub.conf.
Comment 12 Chuck Ebbert 2007-08-13 17:43:32 EDT
Also, try blacklisting the ssb driver by adding this line to
/etc/modprobe.d/blacklist:

blacklist ssb


Comment 13 Piotr Kral 2007-08-16 17:07:06 EDT
I'm afraid that nothing worked -  the system still hangs
Comment 14 Christopher Brown 2007-09-16 16:47:56 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest release? The latest Live CD is
available from:

http://fedoraproject.org/wiki/Distribution/Download

and it would be good to know if this resolves this issue for you.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 15 Piotr Kral 2007-09-17 15:22:58 EDT
Hi. Thanks for interest.
To be frank I've gave up and I've bought new modem with HSDPA. But I've checked
today the old one and it works!! ;-) On kernel 2.6.22.4-65.fc7 it still hangs
but on 2.6.22.5-76.fc7 it's working fine. I have no idea what has changed, but I
think I can close this bug ;-)
Comment 16 Christopher Brown 2007-09-17 15:43:44 EDT
Great news Piotr, I'm just adjusting the closed resolution to highlight what
fixed it for you.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.