Bug 243663 - PCI-X / PCI-Express hot-plug does not work
PCI-X / PCI-Express hot-plug does not work
Status: CLOSED DUPLICATE of bug 230742
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Martin Jenner
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 07:53 EDT by Miho Iwanaga
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 10:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miho Iwanaga 2007-06-11 07:53:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
When I execute PCI-X / PCI-Express HotPlug, the following command fails.
    modprobe -a acpiphp

The details of this phenomenon are mentioned in the following URL.

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=aeb1104814e1177b865eec4f4b364602f5fcb6d1

Version-Release number of selected component (if applicable):
kernel-2.6.18

How reproducible:
Always


Steps to Reproduce:
1. Execute "modprobe -a acpiphp" command
2.
3.

Actual Results:
Error occurred.

Expected Results:
The "modprobe -a acpiphp" command succeeds.

Additional info:
This patch was incorporated in the kernel 2.6.19.
Comment 3 RHEL Product and Program Management 2007-07-18 12:48:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Prarit Bhargava 2007-07-18 13:30:02 EDT
The code base in RHEL5.1's drivers/acpi/events was heavily modified & updated to
the most recent upstream version by BZ 223290.  That modification incorporates
this fix.

Please contact Hitachi's on site representative, Hideo Aoki (haoki@redhat.com)
for details in obtaining a 5.1 kernel.

P.

*** This bug has been marked as a duplicate of 223290 ***
Comment 5 Prarit Bhargava 2007-07-18 13:31:31 EDT
Sorry -- last comment was erroneously marked private.  Un-privating comment.
Comment 6 Prarit Bhargava 2007-08-07 10:35:43 EDT
There appears to have been some IT & BZ breakage.

There are two ITs and several BZs that need to be fixed/updated, and some
RHKL submits need to be cleaned up.
 
1.  IT 124256 should not be linked to 223290 even though it is _part_ of what
is needed but is not the exact patch that is needed.

2.  Luming Yu's (luyu@redhat.com) post

[RHEL 5.1 PATCH] BZ 223290  ACPICA: _CID support for PCI Root Bridge detection.

should be

BZ 230742

3.  The status of 230742 needs to be in some QA state to match that of 223290.

Doug has informed me that RH QA cannot QA this issue -- it requires a manual
undocumented procedure that requires the "right" system, the "right" firmware,
etc..

IMO, this should be PARTNER_QA and Doug has verified that this functions
properly.

4.  IT 124256 references BZ 243663 which was closed as a dup of 223290.
It should be a dup of 230742. (Prarit's note: This was closed as a dup of
223290 based on Luming's RHKL post)

5.  223290 should not be ON_QA.  There are TWO patches required for this
support and only one of them (BZ 230742) is in RHEL5.1.

7.  Management has pushed 223290 support to RHEL5.2.

*** This bug has been marked as a duplicate of 230742 ***

Note You need to log in before you can comment on or make changes to this bug.