Bug 243668 - Wrong init script
Summary: Wrong init script
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: freeradius   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 243667
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-11 12:03 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-07 23:11:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Marciniszyn 2007-06-11 12:03:29 UTC
+++ This bug was initially created as a clone of Bug #243667 +++

Description of problem:
The radiusd init script returns incorrect error codes and some constructions in
it may cause non-calling of status command. For example:
[ -f $RADIUSD ] || exit 0
[ -f $CONFIG ] || exit 0

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

Comment 1 Red Hat Bugzilla 2007-09-17 05:20:01 UTC
transferred from Thomas Woerner to John Dennis, requested by Steve Grubb.

Comment 2 John Dennis 2010-01-07 23:11:58 UTC
Thank you for your bug report. The init script in Fedora (F-12) and the soon to be released new version of freeradius (e.g. freeradius2) in RHEL 5 have fixed the init script issues. I'm going to close this as WONTFIX because this was filed against RHEL 4 and this particular issue does not seem to warrant the costs associated with issuing a RHEL errata (especially since more current versions have addressed the issue).


Note You need to log in before you can comment on or make changes to this bug.