Bug 243673 - Wrong init script
Wrong init script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: radvd (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Bacovsky
:
Depends On: 243672
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 08:08 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-1091
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 08:55:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-06-11 08:08:36 EDT
+++ This bug was initially created as a clone of Bug #243672 +++

Description of problem:
The radvd init script returns some incorrect error codes and some constructions
in it also prevent correct status command call. For example:
[ x${NETWORKING_IPV6} = "xyes" ] || exit 0
[ -f /usr/sbin/radvd ] || exit 0

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Martin Bacovsky 2007-08-21 09:19:23 EDT
re-proposed to 4.7
Comment 3 Martin Bacovsky 2007-11-27 05:50:38 EST
This issue should be fixed in radvd-0.7.2-10.el4
Comment 7 errata-xmlrpc 2007-12-05 08:55:03 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1091.html

Note You need to log in before you can comment on or make changes to this bug.