Bug 243674 - Wrong init script
Wrong init script
Status: CLOSED DUPLICATE of bug 247041
Product: Fedora
Classification: Fedora
Component: radvd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Bacovsky
Ben Levenson
:
Depends On: 243672
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 08:11 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 07:47:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-06-11 08:11:01 EDT
+++ This bug was initially created as a clone of Bug #243672 +++

Description of problem:
The radvd init script returns some incorrect error codes and some constructions
in it also prevent correct status command call. For example:
[ x${NETWORKING_IPV6} = "xyes" ] || exit 0
[ -f /usr/sbin/radvd ] || exit 0

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Martin Bacovsky 2007-08-03 07:47:46 EDT

*** This bug has been marked as a duplicate of 247041 ***

Note You need to log in before you can comment on or make changes to this bug.