Bug 243676 - Wrong init script
Wrong init script
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rarpd (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Honza Horak
qe-baseos-daemons
: Patch
Depends On: 243675
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 08:14 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 13:43:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix init script like in fedora (2.00 KB, patch)
2011-09-27 08:33 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Michal Marciniszyn 2007-06-11 08:14:27 EDT
+++ This bug was initially created as a clone of Bug #243675 +++

Description of problem:
The rarpd init script returns some incorrect error codes and there are
constructions in the script that prevent correct status command call. For example:
test -x /usr/sbin/rarpd -a -f /etc/ethers || exit 0

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

-- Additional comment from pm-rhel@redhat.com on 2007-06-11 08:14 EST --
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 1 Ondrej Vasik 2011-02-18 06:40:18 EST
As RHEL-4.9 is last update for RHEL-4 and it is not suitable for new features
and should address only security, performance and critical issues, I'm moving
the bugzilla to RHEL-5. Package is not present in RHEL-6.
Comment 4 Honza Horak 2011-09-27 08:33:35 EDT
Created attachment 525111 [details]
patch to fix init script like in fedora

This patch fixes the init script in the same way as it's done in Fedora.
Comment 10 Honza Horak 2013-03-13 13:43:20 EDT
There is no chance to fix this in RHEL-5 any more, since RHEL 5.10 is going to include only serious fixes. rarpd is not in RHEL-6, so closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.