Bug 243681 - Wrong init script
Wrong init script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iprutils (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Roman Rakus
Milan Zazrivec
:
Depends On: 243679
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 08:46 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0697
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:49:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-06-11 08:46:27 EDT
+++ This bug was initially created as a clone of Bug #243679 +++

Description of problem:
The rdisc init scrip returns some incorrect error codes and some constructions
in it also prevents correct status command call.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

-- Additional comment from pm-rhel@redhat.com on 2007-06-11 08:23 EST --
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 1 RHEL Product and Program Management 2007-06-11 08:54:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 David Cantrell 2007-08-21 16:48:22 EDT
No time now, low priority, bumping to 4.7.
Comment 3 David Cantrell 2007-11-19 14:08:23 EST
Init scripts have been fixed in the iprutils-2.2.7-2.el4 build, which has been
tagged and built.  Moving bug to MODIFIED.
Comment 5 Milan Zazrivec 2008-05-12 11:42:40 EDT
One thing that really eludes me is why the comment #0 tells stuff
about rdisc init script (part of iputils) package but the bugzilla itself
is assigned to iprutils package (not the same thing as iputils) and is also
part of iprutils RHEL4.7 errata.
Comment 6 Milan Zazrivec 2008-05-14 04:34:36 EDT
OK, I decided to treat this bugzilla as an iprutils bugzilla.

I don't know how important this is, but I think following line:

exit $RETVAL

should be added to the very bottom of:

/etc/rc.d/init.d/iprdump
/etc/rc.d/init.d/iprinit
/etc/rc.d/init.d/iprupdate

Other than that, the init scripts seem fine.
Comment 7 Milan Zazrivec 2008-05-23 05:01:21 EDT
Verified with iprutils-2.2.8-1.el5
Comment 9 errata-xmlrpc 2008-07-24 15:49:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0697.html

Note You need to log in before you can comment on or make changes to this bug.