Bug 243682 - Wrong init script
Wrong init script
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: iprutils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Roman Rakus
bzcl34nup
:
Depends On: 243679
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 08:47 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 02:39:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-06-11 08:47:02 EDT
+++ This bug was initially created as a clone of Bug #243679 +++

Description of problem:
The rdisc init scrip returns some incorrect error codes and some constructions
in it also prevents correct status command call.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

-- Additional comment from pm-rhel@redhat.com on 2007-06-11 08:23 EST --
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 1 Red Hat Bugzilla 2007-08-21 01:34:46 EDT
User pnasrat@redhat.com's account has been closed
Comment 2 Bug Zapper 2008-04-04 08:47:34 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 3 Fedora Update System 2008-08-12 06:49:53 EDT
iprutils-2.2.6-4.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-09-10 02:43:24 EDT
iprutils-2.2.6-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iprutils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7470
Comment 5 Fedora Update System 2008-10-01 02:39:37 EDT
iprutils-2.2.6-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.