Bug 243694 - X server crashes when starting f-spot
X server crashes when starting f-spot
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 09:29 EDT by Samuel Irlapati
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 11:04:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuel Irlapati 2007-06-11 09:29:51 EDT
Description of problem: X server crashes when starting f-spot.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Log into a gnome desktop session
2. Start f-spot
3.
  
Actual results:X server crashes. It takes me back to a console prompt and then
the X server restarts.


Expected results:


Additional info:
Comment 1 Samuel Irlapati 2007-06-11 09:31:49 EDT
Here are the last few lines of Xorg log file.

(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded
(II) 3rd Button detected: disabling emulate3Button

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x6d) [0x48b20d]
1: /lib64/libc.so.6 [0x3c5fc30620]

Fatal server error:
Caught signal 11.  Server aborting

Comment 2 Samuel Irlapati 2007-06-11 09:33:54 EDT
This happens when starting Beryl too.

I have an nvidia card. Below is my xorg.conf file.

# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"


EndSection

Section "Module"
	Load  "fbdevhw"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "glx"
	Load  "dbe"
	Load  "extmod"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Monitor"

	Identifier   "Monitor0"
	ModelName    "LCD Panel 1280x1024"
 ### Comment all HorizSync and VertSync values to use DDC:
	HorizSync    31.5 - 67.0
	VertRefresh  50.0 - 75.0
	Option	    "dpms"
	Option	    "SWCursor"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	Option	    "TripleBuffer" "True"
	Option	    "AllowGLXWithComposite" "True"
	Option	    "RenderAccel" "True"
	Option	    "DisableGLXRootClipping" "True"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768"
"800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768"
"800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
	Option	    "RenderAccel" "Enable"
EndSection
Comment 3 Matěj Cepl 2007-06-12 11:04:58 EDT
Thanks for the report. I am sorry, that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.