Bug 243696 - python-GeoIP needs to expose countrycode->continent and ->countryname lists
Summary: python-GeoIP needs to expose countrycode->continent and ->countryname lists
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-GeoIP   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Michael Fleming
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-11 13:54 UTC by Matt Domsch
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 1.2.1-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 18:01:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add country code info (1.08 KB, patch)
2007-09-04 23:25 UTC, Ignacio Vazquez-Abrams
no flags Details | Diff

Description Matt Domsch 2007-06-11 13:54:31 UTC
Description of problem:
python-GeoIP doesn't expose the countrycode->continent or
countrycode->countryname mappings which are present in GeoIP.  Mirrormanager
would like to make use of these mappings.

Version-Release number of selected component (if applicable):
1.2.1-6.fc7

Comment 1 Ignacio Vazquez-Abrams 2007-09-04 23:25:34 UTC
Created attachment 186711 [details]
Patch to add country code info

Comment 2 Michael Fleming 2007-09-05 10:11:19 UTC
Ignacio, you're a prince among men! (my C-fu is not that strong..)

I'll try a local compile with the patch you've submitted and report how it goes.

Cheers,
Michael.

Comment 3 Matt Domsch 2007-09-05 11:50:22 UTC
amen, much thanks to Ignacio.  I built and tested this on rawhide i386 and it
works beautifully.  I've also sent the patch to sales@maxmind.com, and asked
them to relicense python-GeoIP under the LGPL (instead of the GPLv2+ it is now).
 I'm kind of annoyed that libgeoip is licensed LGPL, but some of their language
bindings to it are licensed GPLv2.

Comment 4 Matt Domsch 2007-09-05 14:41:27 UTC
Wow, they re-licensed it!  Yea!


Date: Wed, 05 Sep 2007 09:50:55 -0400
From: William Stevenson <wdstevenson@maxmind.com>
To: Matt Domsch <matt@domsch.com>
Subject: Re: python-GeoIP license, enhancement patch

Matt,

Thanks for writing and thanks for integrating us. The code has been
checked into the sourceforge CVS under the new license.

If you have any more questions, please let me know.

Thanks,

William

William Stevenson
Business Development Associate
wdstevenson@maxmind.com



Comment 5 Michael Fleming 2007-09-13 07:38:48 UTC
I've checked in the patch and tagged it ready to go for devel (buildroots are
plauing up right now, I'll wait).

Anyone for a backport to earlier Fedoras and/or EPEL? I would imagine the latter
group would appreciate it.

Comment 6 Matt Domsch 2007-09-13 12:03:13 UTC
yes please, at least for Fedora 6 and 7, as that's what Fedora Infrastructure
has in production for this app, though it may move to RHEL5 at some point.

Comment 7 Michael Fleming 2007-09-13 12:52:03 UTC
Due to push to F7-updates-testing, building for devel, also should be built for
FC6 and EPEL (4&5)

I'll close the bug once I've confirmed they've hit the repos.

Comment 8 Fedora Update System 2007-09-18 03:13:49 UTC
python-GeoIP-1.2.1-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2007-09-24 18:01:52 UTC
python-GeoIP-1.2.1-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.