Bug 243708 - Wrong init script
Wrong init script
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rusers (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Honza Horak
qe-baseos-daemons
: Patch
Depends On: 243707
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 10:17 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 13:35:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch for rusersd.init and rstatd.init (4.09 KB, patch)
2011-06-16 11:23 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Michal Marciniszyn 2007-06-11 10:17:51 EDT
+++ This bug was initially created as a clone of Bug #243707 +++

Description of problem:
The rstatd and rusersd init scripts return wrong error codes. There are also
constructions in these scripts that prevent correct status command call, for
example:
if [ ${NETWORKING} = "no" ]
then
        exit 0
fi

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Ondrej Vasik 2011-02-18 06:38:42 EST
As RHEL-4.9 is last update for RHEL-4 and it is not suitable for new features
and should address only security, performance and critical issues, I'm moving
the bugzilla to RHEL-5. Init script was fixed in RHEL-6.
Comment 3 Honza Horak 2011-06-16 11:23:46 EDT
Created attachment 505075 [details]
proposed patch for rusersd.init and rstatd.init

This patch fixes rusersd.init and rstatd.init using the following changes:
* fixes a return code when networking isn't up in rusersd.init and this test is moved to start/stop actions
* tries to start portmap if stopped in rstatd.init (the same behavior as it
already is in rusers.init)
* checks if binding to portmap was successful in both init scripts (this is a
simple way how to find out if a child has been initiated correctly, while the
parent process always returns "0" right after fork)

Any comments to this patch are welcome.
Comment 10 Honza Horak 2013-03-13 13:35:28 EDT
This bug has been fixed in RHEL-6 and there is no chance to fix this in RHEL-5 any more, since RHEL 5.10 is going to include only serious fixes.

Note You need to log in before you can comment on or make changes to this bug.