Bug 243711 - Wrong init script
Wrong init script
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rwho (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Honza Horak
qe-baseos-daemons
: Patch
Depends On: 243710
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 10:27 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 13:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for rwhod.init to be same as RHEL-6 (2.47 KB, patch)
2011-07-21 11:48 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Michal Marciniszyn 2007-06-11 10:27:13 EDT
+++ This bug was initially created as a clone of Bug #243710 +++

Description of problem:
The rwhod init script return incorrect error codes and following construction
may prevent the correct status command call:
if [ ${NETWORKING} = "no" ] ; then
        exit 0
fi

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Ondrej Vasik 2011-02-22 04:07:50 EST
As 4.9 is the last maintainance release of RHEL-4. This problem was fixed in RHEL-6 , in RHEL-5 it still exists, but the report https://bugzilla.redhat.com/show_bug.cgi?id=243710 was closed DEFERRED by pm bot. So moving that one report to RHEL-5 (as we probably could fix the initscript in some fastrack.
Comment 10 Honza Horak 2013-03-13 13:33:24 EDT
This bug has been fixed in RHEL-6 and there is no chance to fix this in RHEL-5 any more, since RHEL 5.10 is going to include only serious fixes.

Note You need to log in before you can comment on or make changes to this bug.