Bug 243713 - Wrong init script
Wrong init script
Status: CLOSED DUPLICATE of bug 247049
Product: Fedora
Classification: Fedora
Component: rwho (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Moskovcak
Ben Levenson
:
Depends On: 243710
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 10:28 EDT by Michal Marciniszyn
Modified: 2015-02-01 17:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 09:44:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-06-11 10:28:40 EDT
+++ This bug was initially created as a clone of Bug #243710 +++

Description of problem:
The rwhod init script return incorrect error codes and following construction
may prevent the correct status command call:
if [ ${NETWORKING} = "no" ] ; then
        exit 0
fi

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Jiri Moskovcak 2007-07-23 09:44:56 EDT

*** This bug has been marked as a duplicate of 247049 ***

Note You need to log in before you can comment on or make changes to this bug.