Bug 243714 - koji mod_python error while trying to download generated SRPM
koji mod_python error while trying to download generated SRPM
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 10:30 EDT by Jeroen Janssen
Modified: 2013-01-09 20:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 16:23:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeroen Janssen 2007-06-11 10:30:20 EDT
Description of problem:

I get the following error when trying to download the SRPM from 
http://koji.fedoraproject.org/koji/taskinfo?taskID=28633

Mod_python error: "PythonHandler mod_python.publisher"

Traceback (most recent call last):

  File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 299, in
HandlerDispatch
    result = object(req)

  File "/usr/lib/python2.4/site-packages/mod_python/publisher.py", line 213, in
handler
    published = publish_object(req, object)

  File "/usr/lib/python2.4/site-packages/mod_python/publisher.py", line 412, in
publish_object
    return publish_object(req,util.apply_fs_data(object, req.form, req=req))

  File "/usr/lib/python2.4/site-packages/mod_python/util.py", line 439, in
apply_fs_data
    return object(**args)

TypeError: getfile() takes exactly 3 non-keyword arguments (2 given)

</pre>


Version-Release number of selected component (if applicable):


How reproducible:

I got it once, and while tryin to reproduce it seems koji is busy doing
something but nothing happens.

Steps to Reproduce:
1. go to http://koji.fedoraproject.org/koji/taskinfo?taskID=28633
2. download SRPM
3. look at the downloaded data
  
Actual results:

file containing mod_python error

Expected results:

the SRPM

Additional info:
Comment 1 Mike Bonnet 2007-06-12 12:31:13 EDT
Works for me.  Did you actually try to download it from the command-line using
wget/curl?  If so, you need to put quotes around the URL, or the & gets
interpreted by the shell and you don't pass the filename to the server, which is
why it's complaining about a missing argument.
Comment 2 Jesse Keating 2007-06-12 16:23:36 EDT
Lets just close this WORKSFORME as I can't duplicate.  This /may/ have been
during the time that httpd was getting OOM killed on koji.fp.org.

Note You need to log in before you can comment on or make changes to this bug.