Bug 243723 - many "4gb seg fixup" syslog messages
many "4gb seg fixup" syslog messages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Brian Brock
http://lists.xensource.com/archives/h...
:
Depends On: 215201
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 11:03 EDT by Eduardo Habkost
Modified: 2007-11-30 17:12 EST (History)
13 users (show)

See Also:
Fixed In Version: 2.6.20-1.2941
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 15:29:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2007-06-11 11:03:52 EDT
FC6 clone of bug #215201.

+++ This bug was initially created as a clone of Bug #215201 +++

Description of problem:

After upgrading to FC6 the following shows up in syslog:

> 4gb seg fixup, process compiz (pid 1162), cs:ip 73:008d8cfc
> printk: 185714 messages suppressed.

The mentioned URL suggests:

> echo 'hwcap 0 nosegneg' > /etc/ld.so.conf.d/libc6-xen.conf

> Should this go to the fedora folks?

> So, yes, it would seem? As the spec file for the xen rpm should make
> the ld.so adjustment above, right?

For practical purposes I reverted to FC4, so I haven't been able to test it 
myself.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-1.2798.fc6.i686.rpm

How reproducible: 100%

Steps to Reproduce:
1. Install FC6
2. Use Compiz
3. Enjoy the syslog messages
  
Actual results:

A lot of messages

Expected results:

No messages

Additional info: I searched bugzilla for similar reports, and havent found 
any.
  Experience makes me expect however that this will be classified as a 
duplicate.

-- Additional comment from rs@bugzilla.redhat.spam.futz.org on 2006-11-15 
14:55 EST --
This is also occurring on FC5 (2.6.18-1.2239.fc5xenU), with various 
components.
nash-hotplug and pvscan are the 2 I've seen most recently.

This is with /etc/ld.conf.so.d/kernelcap-2.6.18-1.2239.fc5.conf containing
hwcap 0 nosegneg


-- Additional comment from bugzilla-redhat@spamwatching.com on 2006-11-25 
06:00 EST --
I can confirm seeing this bug on a fresh install of FC6 running Xen kernels.

Compiz was the biggest culprit, but after killing the Desktop Effects feature, 
I
still see entries for Xorg at system boot and "gnome-screensav" whenever the
screensaver kicks in.

I also have "hwcap 0 nosegneg" in the appropriate
/etc/ld.conf.so.d/kernelcap-$(uname -r).conf file.

Will gladly provide more information as necessary.

-- Additional comment from rolf.fokkens@wanadoo.nl on 2006-11-27 03:54 EST --
Currently I have "hwcap 0 nosegneg" in /etc/ld.so.conf.d/libc6-xen.conf:

[root@home01 ~]# grep "4gb seg fixup" /var/log/messages | awk '{ print 
$10 }' |
sort | uniq -c
     22 beagle-build-in
  15481 beagled
   1104 beagled-helper
     24 compiz
     24 gnome-screensav
      1 mkinitrd
      1 mono
    131 prelink
      5 sh
     18 yum
[root@home01 ~]# 

I just reenabled compiz, which explains the low count.


-- Additional comment from jwest@redhat.com on 2006-12-08 00:47 EST --
I also have "hwcap 0 nosegneg" in /etc/ld.so.conf.d/libc6-xen.conf

[root@fc6test ~]# grep "4gb seg fixup" /var/log/messages | awk '{ print $10
}'|sort | uniq -c
      1 amarokapp
     42 beagle-build-in
  39128 beagled
   3024 beagled-helper
  25848 beryl
     13 glxinfo
     49 gnome-screensav
     22 mono
      1 mplayer
      1 prelink
     39 Xorg

I've also seen the same messages on RHEL5 Beta2 just as a note.

-- Additional comment from jan.kratochvil@redhat.com on 2006-12-22 18:27 
EST --
I believe this Bug is a duplicate of RHEL5 glibc Bug 220675.  This Bug should
get rechecked after its fix.
Please check your environment variable `LD_LIBRARY_PATH'.


-- Additional comment from redhat@hoekstra.nu on 2007-01-03 06:54 EST --
Apologies for adding to this bug if it is irrelevant, but I get the same 
messages..

I reckon that my machine has 2GB memory, while 'cat /proc/meminfo' tells me I
have only MemTotal of 1020Mb (on Xen0).

The LowTotal value tells me I have 4TB (!) of memory. 

I am curious if this has something to do with this bug report? Otherwise I 
will
report a new bug with more details.

-- Additional comment from jan.kratochvil@redhat.com on 2007-01-03 07:02 
EST --
(In reply to comment #6)
> I am curious if this has something to do with this bug report? Otherwise I 
will
> report a new bug with more details.

It looks really unrelated. Please attach all the relevant files, like
/var/log/dmesg, /proc/meminfo, /proc/cmdline, /var/log/xen/baloon (?),
/etc/grub.conf or others you will find relevant.


-- Additional comment from berrange@redhat.com on 2007-01-03 07:22 EST --
wrt to comment #6

> Apologies for adding to this bug if it is irrelevant, 
> but I get the same messages..
>
> I reckon that my machine has 2GB memory, while 'cat /proc/meminfo' 
> tells me I have only MemTotal of 1020Mb (on Xen0).
>
> The LowTotal value tells me I have 4TB (!) of memory. 

This is totally unrelated to the '4gb fixup'  messages - please create a
separate bug if you wish to pursue your issue in comment #6.

-- Additional comment from bjohnson@symetrix.com on 2007-02-16 06:13 EST --
It seems that this problem was fixed in RHEL5-rc1 about a week ago.  Can we 
get
it propogated to FC6/devel??

-- Additional comment from jan.kratochvil@redhat.com on 2007-02-16 06:57 
EST --
(In reply to comment #9)
> It seems that this problem was fixed in RHEL5-rc1 about a week ago.  Can we 
get
> it propogated to FC6/devel??

Could you be more specific? Running on RawHide (devel) and no messages are 
seen.
glibc-2.5.90-17.i686
kernel-xen-2.6.19-1.2898.2.3.fc7.i686


-- Additional comment from bjohnson@symetrix.com on 2007-02-16 07:16 EST --
(In reply to comment #10)
> Could you be more specific? Running on RawHide (devel) and no messages are 
seen.
> glibc-2.5.90-17.i686
> kernel-xen-2.6.19-1.2898.2.3.fc7.i686

glibc-2.5-10.fc6
kernel-xen-2.6.19-1.2911.fc6

I haven't checked rawhide, but my FC6 box (fully updated) spits out a 
continuous
stream of messages.

By the requirements of http://fedoraproject.org/wiki/Legacy/Mock I had
kernel.vdso=0 on my system.  I just checked changing that (undefined ->
kernel.vdso=1) and that had no effect.

Are you implying that this bug should be fixed for FC6?



-- Additional comment from jan.kratochvil@redhat.com on 2007-02-16 19:34 
EST --
Confirming it is a valid FC6+devel Bug. Fix of Bug 220675 (RHEL5) should be 
ported.
(My Comment 10 was not right.)

See the offset 0x490 according to Jakub's Bug 220675 Comment 2:

kernel-xen-2.6.18-8.el5.i686 (RHEL5, correct)
objdump -s -j .note /tmp/vdso
/tmp/vdso:     file format elf32-i386
Contents of section .note:
 0460 06000000 04000000 00000000 4c696e75  ............Linu
 0470 78000000 12060200 04000000 12000000  x...............
 0480 02000000 474e5500 01000000 01000000  ....GNU.........
 0490 006e6f73 65676e65 67000000           .nosegneg...    

kernel-xen-2.6.19-1.2911.fc6.i686 (FC6, incorrect)
objdump -s -j .note /tmp/vdso
/tmp/vdso:     file format elf32-i386
Contents of section .note:
 0460 06000000 04000000 00000000 4c696e75  ............Linu
 0470 78000000 13060200 04000000 12000000  x...............
 0480 02000000 474e5500 01000000 01000000  ....GNU.........
 0490 016e6f73 65676e65 67000000           .nosegneg...    

kernel-xen-2.6.19-1.2898.2.3.fc7.i686 (devel, incorrect)
objdump -s -j .note /tmp/vdso

/tmp/vdso:     file format elf32-i386

Contents of section .note:
 0460 06000000 04000000 00000000 4c696e75  ............Linu
 0470 78000000 13060200 04000000 12000000  x...............
 0480 02000000 474e5500 01000000 01000000  ....GNU.........
 0490 016e6f73 65676e65 67000000           .nosegneg...    


-- Additional comment from bjohnson@symetrix.com on 2007-03-03 12:45 EST --
*** Bug 230047 has been marked as a duplicate of this bug. ***

-- Additional comment from bjohnson@symetrix.com on 2007-03-03 12:47 EST --
This is still not resolved in:
2.6.19-1.2911.6.4.fc6

-- Additional comment from hps@intermeta.de on 2007-04-14 12:17 EST --
Any news here? I'm seeing the same behaviour using 2.6.20-1.2312.fc5 on a 
fully
patched FC5 machine. 

I have no LD_LIBRARY_PATH variable and ldconfig reports that I am using
correctly the nosegneg versions:

 /sbin/ldconfig -N -p | grep nosegneg
        libthread_db.so.1 (libc6, hwcap: 0x0018000000000000, OS ABI: Linux
2.6.9) => /lib/i686/nosegneg/libthread_db.so.1
        librt.so.1 (libc6, hwcap: 0x0018000000000000, OS ABI: Linux 2.6.9) =>
/lib/i686/nosegneg/librt.so.1
        libpthread.so.0 (libc6, hwcap: 0x0018000000000000, OS ABI: Linux 
2.6.9)
=> /lib/i686/nosegneg/libpthread.so.0
        libm.so.6 (libc6, hwcap: 0x0018000000000000, OS ABI: Linux 2.6.9) =>
/lib/i686/nosegneg/libm.so.6
        libc.so.6 (libc6, hwcap: 0x0018000000000000, OS ABI: Linux 2.6.9) =>
/lib/i686/nosegneg/libc.so.6

Still the messages appear on the console of the client. Running ldconfig is 
the
easiest way to provoke it:

4gb seg fixup, process ldconfig (pid 1001), cs:ip 73:0805a702
printk: 3604 messages suppressed.
4gb seg fixup, process ldconfig (pid 1024), cs:ip 73:0805a702
4gb seg fixup, process ldconfig (pid 1024), cs:ip 73:0805a702
4gb seg fixup, process ldconfig (pid 1024), cs:ip 73:0805a702
4gb seg fixup, process ldconfig (pid 1024), cs:ip 73:0805a702
printk: 848 messages suppressed.
4gb seg fixup, process ldconfig (pid 1025), cs:ip 73:0805a702

ad infinitum, ad nauseam.

-- Additional comment from bjohnson@symetrix.com on 2007-06-09 04:30 EST --
Still not resolved in 2.6.20-2925.9.fc7xen
Comment 1 Eduardo Habkost 2007-07-11 15:29:50 EDT
The patch from bug #220675 is already present 2.6.20-1.2941 and later.

Note You need to log in before you can comment on or make changes to this bug.