Bug 243725 - RFE: Provide a method to use yum plugins with mock
RFE: Provide a method to use yum plugins with mock
Status: CLOSED WORKSFORME
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 11:04 EDT by Jesse Keating
Modified: 2013-01-09 23:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 10:50:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-06-11 11:04:09 EDT
Right now there doesn't appear to be a method of using yum plugins.  This could
be useful, if I ever write the plugin to prefer downloading from one repo
instead of others when all things are equal.
Comment 1 Carl Roth 2008-04-17 11:13:15 EDT
Is there another example that you can think of?  Repository selection and
priority specification isn't really an issue with mock because the yum
repositories are completely spelled out in each chroot configuration.  That is,
in my build environment I use alternate chroot configuration files specifically
for that purpose.
Comment 2 Michael E Brown 2008-04-17 13:07:33 EDT
yum plugins *should* just work if you enable them in the config file. You just
have to be careful because all plugins that are enabled on the host will be used.
Comment 3 Ricky Zhou 2009-08-05 12:52:46 EDT
Hey, is this still an issue?  Also, just curious - is this still the main product in bugzilla where mock bugs are tracked?  I'd be nice to get rid of the fedora hosted product soon because it seems to cause a lot of confusion with where to properly submit bugs :-/
Comment 4 Clark Williams 2009-08-05 13:34:08 EDT
it would be nice to consolidate bug reports and patch submission but that's going to be tough, since we have mock for both Fedora and RHEL (or EPEL if you prefer). 

As far as the RFE goes, I think we need to ask Jesse if we need something besides the mock config file to manipulate yum plugins.
Comment 5 Jesse Keating 2009-08-12 20:01:51 EDT
mock config file is just fine.
Comment 6 Clark Williams 2009-08-13 10:50:29 EDT
Ok, I'm closing as worksforme

Note You need to log in before you can comment on or make changes to this bug.