Bug 243740 - Apache resource agent script is not starting httpd
Apache resource agent script is not starting httpd
Status: CLOSED DUPLICATE of bug 235178
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Marek Grac
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 12:44 EDT by Kyle Gonzales
Modified: 2009-04-16 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 15:19:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle Gonzales 2007-06-11 12:44:27 EDT
Opening this after checking with Lon H about correct behavior.

Description of problem:

In the service definition for Conga, if you add the local resource Apache to the
system, it does NOT configure the httpd service script for you.  All you get it
something like this:

<service autostart="1" domain="course_failover" exclusive="0" name="httpd"
recovery="restart">
     <apache config_file="conf/httpd.conf" name="httpd" server_root="/etc/httpd"
shutdown_wait="0"/>
</service>

You have to define a script resource, and set the path to get httpd to start.


Version-Release number of selected component (if applicable):
]# rpm -q luci ricci
luci-0.9.2-6.el5
ricci-0.9.2-6.el5


How reproducible:
Everytime.

Steps to Reproduce:
1. Define a service
2. Add local resource type Apache
3. Check of /etc/cluster/cluster.conf shows no script service defined for httpd
  
Actual results:
Selecting the Apache local resource does not add the httpd script resource.  The
service does not start.

Expected results:
Selecting the Apache local resource will provide for adding the httpd script
resource.


Additional info:
Comment 1 Lon Hohberger 2007-06-12 11:43:15 EDT
Correction: the resource agent is not correctly starting httpd; there doesn't
need to be a script resource added.
Comment 2 Ryan McCabe 2007-06-12 11:50:06 EDT
Moving this to rgmanager given the comment above. Please yell if this is the
wrong thing to do.
Comment 3 Kyle Gonzales 2007-06-12 12:43:31 EDT
So this is an rgmanager problem, not a Conga issue

Is rgmanager supposed to start httpd when it sees the Apache resource config
line in cluster.conf?
Comment 4 Marek Grac 2007-06-14 08:38:20 EDT
Yes, it is supposed to run httpd but you should provide IP addresses (or modify
the generated config file). So correct usage should be:

<service autostart="0" name="web00">
     <ip address="10.34.32.168"/>
     <apache config_file="conf/httpd.conf" name="httpd" server_root="/etc/httpd"
shutdown_wait="0"/>
</service>

But there is a bug because rgmanager attempts to stop service first and it fails
because pid file does not exist. 

Comment 5 Marek Grac 2007-06-19 15:19:35 EDT
Works in current RHEL5/HEAD. No patch needed because it was repaired as a side
effect of bug #235178

Just note: Do not use shutdown_wait="0" because then disabling service will
almost surely fails (it won't wait a second and application won't be stopped
=> fails). Use shutdown_wait="1" or do not use this attribute at all
(default values are more than enough)


*** This bug has been marked as a duplicate of 235178 ***
Comment 6 Nate Straz 2007-12-13 12:18:40 EST
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Note You need to log in before you can comment on or make changes to this bug.