Bug 243759 - resume fails on Fedora 7 with Lenovo X60S (regression from FC6)
resume fails on Fedora 7 with Lenovo X60S (regression from FC6)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 14:48 EDT by John Heidemann
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 06:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Heidemann 2007-06-11 14:48:13 EDT
Description of problem:

Fedora 7's default kernel hangs on resume with Fedora 7
with pm-suspend --quirk-s3-bios
while it worked with FC6 with acpi_sleep=s3_bios on boot.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3194

How reproducible:

every time


Steps to Reproduce:

1. boot an X60S
(my has
dash> lshal|grep system.hardware
  system.hardware.product = '170533U'  (string)
  system.hardware.version = 'ThinkPad X60s'  (string)
)
2. pm-suspend --quirk-s3-bios
(or --quirk-s3-bios and --quirk-s3-mode)
on F7
3. press power button
disk spins, but screen is blank and computer is non-responive to pings,
(the capslock key does toggle the caps lock light, though)

same results even with iwl3945 mac80211 are unloaded


on fc6, if you boot with the option acpi_sleep=s3_bios,
then resume works fine


Actual results:

hung

Expected results:

working machine in X

Additional info:

Work-arounds: running the current FC6 kernel (config-2.6.20-1.2948) and
suspend/resume works in an (otherwi1se) F7 system with --quirk-s3-bios.

This is FIXED in rawhide with 2.6.21-1.3206 (from rawhide).
It regresses in 2.6.21-1.3213.
I still have to test #3218.


Also, a patch is needed to add s3-bios to the hal quirks.
This patch has been sent upstream, see the thread at
http://lists.freedesktop.org/archives/hal/2007-June/008657.html

Since this problem SEEMS to be getting worked out in rawhide,
I'm filing this bug simply to encourage release of an updated kernel (once
rawhide stablizes), and to document this open bug (against F7 gold) for other
X60s users.
Comment 1 Aram Kananov 2007-06-12 07:10:20 EDT
I have X60s 17046DG

I have the same problem with suspend
rawhide 2.6.21-1.3206 works
2.6.21-1.3226.fc7 doesnt
2.6.21-1.3194.fc7 doesnt 

Comment 2 Aram Kananov 2007-06-13 07:22:53 EDT
kernel-2.6.21-1.3228.fc7 also hungs 
Comment 3 Sergio Monteiro Basto 2007-06-28 09:51:23 EDT
I also have a suspend to disk regression problem , on my compaq nx 6110.

I try : 
rpm -iv ~/kernel-2.6.20-1.2962.fc6.src.rpm 
cd /usr/src/redhat/SPECS/
rpmbuild -ba kernel-2.6.spec --with baseonly --target=i686
rpm -ivh /usr/src/redhat/RPMS/i686/kernel-2.6.20-1.2962.fc7.i686.rpm 
and exactly the same system just boot with kernel-2.6.20-1.2962.fc7 I don't have
any problem.
Comment 4 Christopher Brown 2007-09-16 17:07:56 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 5 Bryan O'Sullivan 2007-09-16 18:56:06 EDT
Resume is working okay for me, at least, running an x86_64 F7 2.6.22 kernel.
Comment 6 Aram Kananov 2007-09-17 04:47:05 EDT
Resume works on 2.6.22.5-76.fc7 on i386
Comment 7 Christopher Brown 2007-09-17 06:49:50 EDT
Okay then I'm closing this but please re-open if its still an issue for the
reporter.

Cheers
Chris
Comment 8 John Heidemann 2007-09-17 11:03:50 EDT
Yes, I can confirm that it works for me with kernel-2.6.22.5-76.fc7,
so this bug should now be closed.
(It didn't work as late as the immediately prior 2.6.22 kernel---I think -48.fc7.)

Note You need to log in before you can comment on or make changes to this bug.